summaryrefslogtreecommitdiff
path: root/guix/build/python-build-system.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-04 18:04:15 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-04 18:07:55 +0200
commit3df47231e6c632aadcd7b103bb5b399a8d29772d (patch)
tree423260305ff37b1b742399d3c1021a0c472a37f0 /guix/build/python-build-system.scm
parentee3e314bb7ba376c7e8c95c3da1f64ba07d57847 (diff)
downloadguix-patches-3df47231e6c632aadcd7b103bb5b399a8d29772d.tar
guix-patches-3df47231e6c632aadcd7b103bb5b399a8d29772d.tar.gz
guix: python: Switch to python-wrapper as the default version for the python
build system (switches to Python 3) and compute python-version instead of passing it as a parameter. * guix/build-system/python.scm (default-python): Switch to python-wrapper. * guix/build-system/python.scm (python-build): Drop parameter #:python-version. * guix/build/python-build-system.scm (wrap): Compute python version from input.
Diffstat (limited to 'guix/build/python-build-system.scm')
-rw-r--r--guix/build/python-build-system.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 84299798b0..04c223bb85 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -53,7 +53,7 @@
(zero? (apply system* "python" args)))
(error "no setup.py found")))
-(define* (wrap #:key outputs python-version #:allow-other-keys)
+(define* (wrap #:key inputs outputs #:allow-other-keys)
(define (list-of-files dir)
(map (cut string-append dir "/" <>)
(or (scandir dir (lambda (f)
@@ -69,6 +69,8 @@
outputs))
(let* ((out (assoc-ref outputs "out"))
+ (python (assoc-ref inputs "python"))
+ (python-version (string-take (string-take-right python 5) 3))
(var `("PYTHONPATH" prefix
,(cons (string-append out "/lib/python"
python-version "/site-packages")