summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-07-04 21:01:00 -0300
committerLudovic Courtès <ludo@gnu.org>2021-07-21 15:56:03 +0200
commitee25e3fcab9d2e24c2826b771b52d797c152193b (patch)
treea15a581973ab900713dc96ec231c41d06abb10ee /guix/build-system
parent04e80290bf1023f83649f807ddcd4d980da1747b (diff)
downloadguix-patches-ee25e3fcab9d2e24c2826b771b52d797c152193b.tar
guix-patches-ee25e3fcab9d2e24c2826b771b52d797c152193b.tar.gz
gnu: TeX Live: Update to TeX Live 2021
Use version 20210325 for the tarballs, which is the latest one available on the historical releases repository. And use subversion tag 2021.3 which is the latest one available as well. TeX Live dropped support for using the system’s poppler library after the 2020 version. Quoting from `m4/kpse-xpdf-flags.m4`: # Support for our semi-homegrown libs/xpdf library. This is derived # from xpdf source code, but xpdf does not distribute it as a library. # It is used by pdftex (and nothing else) to read PDF images. # Other engines use the semi-homegrown pplib library (q.v.) for that. # The well-known poppler library is also originally derived from xpdf # source code, but has been greatly revised and extended. TL used to # (sort of) support poppler as the system xpdf, but after the TL 2020 # release we dropped this, because we switched XeTeX to use pplib, and # nothing else used poppler. (No engines ever used poppler to generate # their PDF output). # # poppler is aggressively developed, with requirements for new compilers # and language versions. That's fine for them, but since we don't need # anything new, it has become too time-consuming and problematic to # continue to support it in the TL sources, when we don't have any # requirement for it. Therefore the main change in this commit is making the texlive-bin package use the embedded pplib and xpdf libraries. Another noteworthy change is to texlive-latex-l3packages, which now needs to ship a few pre-generated files that cannot be reproduced during the build process (the comments in the package definition have more details). * guix/build-system/texlive.scm (%texlive-tag): Set to “texlive-2021.3”. (%texlive-revision): Set to 59745. * gnu/packages/tex.scm (hyph-utf8-scripts, texlive-docstrip, texlive-unicode-data texlive-hyphen-base, texlive-metafont, texlive-cm, texlive-courier, texlive-lm, texlive-knuth-lib, texlive-tex-plain, texlive-hyphen-finnish, texlive-hyphen-german, texlive-hyph-utf8, texlive-dehyph-exptl, texlive-kpathsea, texlive-latex-fancyvrb, texlive-graphics-def, texlive-latex-graphics, texlive-hyperref, texlive-oberdiek, texlive-latex-tools, texlive-latex-l3kernel, texlive-l3build, texlive-luaotfload, texlive-latex-amsmath, texlive-amscls, texlive-babel, texlive-generic-babel-german, texlive-babel-swedish, texlive-psnfss, texlive-latex-draftwatermark, texlive-latex-etoc, texlive-etoolbox, texlive-latex-polyglossia, texlive-tex-texinfo, texlive-latex-bookmark, texlive-latex-cmap, texlive-latex-fancyhdr, texlive-latex-kvoptions, texlive-latex-eso-pic, texlive-latex-multirow, texlive-latex-parskip, texlive-latex-pdfpages, texlive-metapost, texlive-latex-acmart, texlive-latex-preview, texlive-latex-acronym, texlive-pdftex, texlive-latex-media9, texlive-latex-ocgx2, texlive-latex-ms, texlive-latex-pgf, texlive-latex-pgf-generic, texlive-latex-koma-script, texlive-generic-ltxcmds, texlive-bibtex, texlive-context-base, texlive-context, texlive-beamer, texlive-pstricks, texlive-tools, texlive-latex-xkeyval, texlive-csquotes, texlive-biblatex, texlive-todonotes, texlive-microtype, texlive-caption, texlive-fontaxes, texlive-cabin, texlive-newtx, texlive-xcharter, texlive-adjustbox, texlive-tcolorbox): Update hash. (texlive-extra-src, texlive-texmf-src): Update version to “20210325”. Update hash. (texlive-bin)[source]: Update version to “20210325”. Update hash. Preserve ‘libs/pplib’ and ‘libs/xpdf’. [inputs]: Update hash for ‘texlive-scripts’. Remove ‘poppler’. [arguments]: Remove “--with-system-poppler” and “--with-system-xpdf” from ‘#:configure-flags’. Remove build phase ‘use-code-for-new-poppler’. (texlive-hyphen-schoolfinnish): Add public variable. (texlive-hyphen-macedonian): Add 8bit patterns. Update hash. (texlive-latex-base)[template]: Update hash. [arguments]: Set ‘LUAINPUTS’ environment variable in build phase. [native-inputs]: Update hash for ‘texlive-luatexconfig’. [propagated-inputs]: Add ‘texlive-hyphen-schoolfinnish’, ‘texlive-latex-l3kernel’ and ‘texlive-latex-l3packages’. (texlive-latex-l3packages)[source]: Use ‘texlive-origin’. Update hash. Add generated files. [arguments]: Adjust paths for ‘TEXINPUTS’ environment variable. Add build phase ‘copy-generated-files’. (texlive-texmf, texlive): Update version to “20210325”. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/texlive.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build-system/texlive.scm b/guix/build-system/texlive.scm
index f3838e580a..09907c67d8 100644
--- a/guix/build-system/texlive.scm
+++ b/guix/build-system/texlive.scm
@@ -45,8 +45,8 @@
;; These variables specify the SVN tag and the matching SVN revision. They
;; are taken from https://www.tug.org/svn/texlive/tags/
-(define %texlive-tag "texlive-2020.0")
-(define %texlive-revision 54632)
+(define %texlive-tag "texlive-2021.3")
+(define %texlive-revision 59745)
(define (texlive-origin name version locations hash)
"Return an <origin> object for a TeX Live package consisting of multiple