summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 11:03:25 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:11:47 +0000
commitfa81c31ce988f05494e79facc50deb1a590fcbb8 (patch)
treeaee5be4a12b080ce6225be2aa5b2410100f88f90 /guix/build-system
parentc3db377d2b4c217adad24ac7ab3fde7326a8436e (diff)
downloadguix-patches-fa81c31ce988f05494e79facc50deb1a590fcbb8.tar
guix-patches-fa81c31ce988f05494e79facc50deb1a590fcbb8.tar.gz
build-system/meson: Allow 'configure-flags' to be a G-exp.
* guix/build-system/meson.scm (meson-build, meson-cross-build): Only call 'sexp->gexp' on 'configure-flags' when 'configure-flags' is a pair.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/meson.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index dae0abde94..dcad3f322d 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -212,7 +212,10 @@ has a 'meson.build' file."
(map search-path-specification->sexp
search-paths))
#:phases build-phases
- #:configure-flags #$(sexp->gexp configure-flags)
+ #:configure-flags
+ #$(if (pair? configure-flags)
+ (sexp->gexp configure-flags)
+ configure-flags)
#:build-type #$build-type
#:tests? #$tests?
#:test-target #$test-target
@@ -309,7 +312,9 @@ SOURCE has a 'meson.build' file."
#:phases build-phases
#:make-dynamic-linker-cache? #$make-dynamic-linker-cache?
#:configure-flags `("--cross-file" #+cross-file
- ,@#$(sexp->gexp configure-flags))
+ ,@#$(if (pair? configure-flags)
+ (sexp->gexp configure-flags)
+ configure-flags))
#:build-type #$build-type
#:tests? #$tests?
#:test-target #$test-target