summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-03 12:07:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:32 -0500
commitdfcc96d8f48716ae5aefb383c58b153d5bcb407c (patch)
treebd78a84d83ef6be838bac8d2910087f6cef8ff8a /guix/build-system
parent3e026fc2b1bd65ead774733fbc5852794d96bf43 (diff)
downloadguix-patches-dfcc96d8f48716ae5aefb383c58b153d5bcb407c.tar
guix-patches-dfcc96d8f48716ae5aefb383c58b153d5bcb407c.tar.gz
build: meson: Replace the 'test-target' argument by 'test-options'.
This change is motivated by the need to disable the default 30 seconds timeout that Meson uses (see: https://gitlab.gnome.org/GNOME/glib/-/issues/2522), and also by desire to specify extra options to run the check phase without having to override it. * guix/build-system/meson.scm (meson-build) <test-target>: Replace argument with... <test-options>: ... this one. * guix/build/meson-build-system.scm (check): Invoke 'meson test' instead of 'ninja test-target', as the former is configurable via options. * doc/guix.texi (Build Systems) <meson-build-system>: Update doc.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/meson.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 198aa08729..ba7441a3eb 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -169,7 +169,7 @@ TRIPLET."
(search-paths '())
(build-type "debugoptimized")
(tests? #t)
- (test-target "test")
+ (test-options ''())
(glib-or-gtk? #f)
(parallel-build? #t)
(parallel-tests? #f)
@@ -218,7 +218,7 @@ has a 'meson.build' file."
configure-flags)
#:build-type #$build-type
#:tests? #$tests?
- #:test-target #$test-target
+ #:test-options #$(sexp->gexp test-options)
#:parallel-build? #$parallel-build?
#:parallel-tests? #$parallel-tests?
#:validate-runpath? #$validate-runpath?
@@ -251,7 +251,7 @@ has a 'meson.build' file."
(build-type "debugoptimized")
(tests? #f)
- (test-target "test")
+ (test-options ''())
(glib-or-gtk? #f)
(parallel-build? #t)
(parallel-tests? #f)
@@ -281,7 +281,7 @@ SOURCE has a 'meson.build' file."
(if (null? target-inputs)
(input-tuples->gexp host-inputs)
#~(append #$(input-tuples->gexp host-inputs)
- #+(input-tuples->gexp target-inputs))))
+ #+(input-tuples->gexp target-inputs))))
(define builder
(with-imported-modules imported-modules
#~(begin
@@ -306,7 +306,7 @@ SOURCE has a 'meson.build' file."
#:native-inputs #+(input-tuples->gexp build-inputs)
#:search-paths '#$(sexp->gexp
(map search-path-specification->sexp
- search-paths))
+ search-paths))
#:native-search-paths '#$(sexp->gexp
(map search-path-specification->sexp
native-search-paths))
@@ -318,7 +318,7 @@ SOURCE has a 'meson.build' file."
configure-flags))
#:build-type #$build-type
#:tests? #$tests?
- #:test-target #$test-target
+ #:test-options #$(sexp->gexp test-options)
#:parallel-build? #$parallel-build?
#:parallel-tests? #$parallel-tests?
#:validate-runpath? #$validate-runpath?