summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-01 21:57:42 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-01 21:57:42 +0200
commit0fd107d86dae686e10fc43c8f92a847fc9fb06e1 (patch)
tree00e1d6dc2018cbc1f9d9011726e66497b4c775ed /guix/build-system
parentb702d1219c4a7e01975a4cc442ed14b3139aeae8 (diff)
downloadguix-patches-0fd107d86dae686e10fc43c8f92a847fc9fb06e1.tar
guix-patches-0fd107d86dae686e10fc43c8f92a847fc9fb06e1.tar.gz
build-system/android-ndk: Fix reference to "android-build".
Regression introduced in 7d873f194ca69d6096d28d7a224ab78e83e34fe1. * guix/build-system/android-ndk.scm (android-ndk-build): Call 'gexp-input-thing' on the item taken from INPUTS.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/android-ndk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/guix/build-system/android-ndk.scm b/guix/build-system/android-ndk.scm
index fa8b1e2f12..d33e1b4830 100644
--- a/guix/build-system/android-ndk.scm
+++ b/guix/build-system/android-ndk.scm
@@ -64,8 +64,9 @@
#:phases #$phases
#:make-flags
(cons* "-f"
- #$(file-append (car (assoc-ref inputs
- "android-build"))
+ #$(file-append (gexp-input-thing
+ (car (assoc-ref inputs
+ "android-build")))
"/share/android/build/core/main.mk")
#$make-flags)
#:outputs #$(outputs->gexp outputs)