summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-10 23:15:57 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-10 23:15:57 +0200
commit7e2b10a53f00d6d2bb2b3c799deeda7cd201338a (patch)
treef0ac752ebef6c6cc2a839532a313d94afe36e3ac /guix/build-system
parentde80b5045b8467c34a7d53a6b62628202595f089 (diff)
downloadguix-patches-7e2b10a53f00d6d2bb2b3c799deeda7cd201338a.tar
guix-patches-7e2b10a53f00d6d2bb2b3c799deeda7cd201338a.tar.gz
build-system/{gnu,cmake}: Remove #:patches and #:patch-flags parameters.
* guix/build/gnu-build-system.scm (patch): Remove. (%standard-phases): Remove 'patch'. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Remove #:patches and #:patch-flags parameters. * guix/build-system/cmake.scm (cmake-build): Likewise. * guix/build-system/python.scm (package-with-explicit-python): Update comment.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/cmake.scm3
-rw-r--r--guix/build-system/gnu.scm6
-rw-r--r--guix/build-system/python.scm5
3 files changed, 2 insertions, 12 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 9461b19a2e..5f5c243572 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -47,7 +47,6 @@
(outputs '("out")) (configure-flags ''())
(search-paths '())
(make-flags ''())
- (patches ''()) (patch-flags ''("--batch" "-p1"))
(cmake (default-cmake))
(out-of-source? #f)
(tests? #t)
@@ -81,8 +80,6 @@ provides a 'CMakeLists.txt' file as its build system."
#:search-paths ',(map search-path-specification->sexp
(append search-paths
(standard-search-paths)))
- #:patches ,patches
- #:patch-flags ,patch-flags
#:phases ,phases
#:configure-flags ,configure-flags
#:make-flags ,make-flags
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 5f13f8ee29..7725b8b67a 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -252,7 +252,6 @@ System: GCC, GNU Make, Bash, Coreutils, etc."
(search-paths '())
(configure-flags ''())
(make-flags ''())
- (patches ''()) (patch-flags ''("--batch" "-p1"))
(out-of-source? #f)
(tests? #t)
(test-target "check")
@@ -300,8 +299,6 @@ which could lead to gratuitous input divergence."
#:search-paths ',(map search-path-specification->sexp
(append implicit-search-paths
search-paths))
- #:patches ,patches
- #:patch-flags ,patch-flags
#:phases ,phases
#:configure-flags ,configure-flags
#:make-flags ,make-flags
@@ -390,7 +387,6 @@ inputs."
(configure-flags ''())
(make-flags ''())
- (patches ''()) (patch-flags ''("--batch" "-p1"))
(out-of-source? #f)
(tests? #f) ; nothing can be done
(test-target "check")
@@ -473,8 +469,6 @@ platform."
search-path-specification->sexp
(append implicit-host-search-paths
native-search-paths))
- #:patches ,patches
- #:patch-flags ,patch-flags
#:phases ,phases
#:configure-flags ,configure-flags
#:make-flags ,make-flags
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index cf7ca7d3e1..32b1f36a94 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -58,9 +58,8 @@ prepended to the name."
(let* ((build-system (package-build-system p))
(rewrite-if-package
(lambda (content)
- ;; CONTENT may be a string (e.g., for patches), in which case it
- ;; is returned, or a package, which is rewritten with the new
- ;; PYTHON and NEW-PREFIX.
+ ;; CONTENT may be a file name, in which case it is returned, or a
+ ;; package, which is rewritten with the new PYTHON and NEW-PREFIX.
(if (package? content)
(package-with-explicit-python content python
old-prefix new-prefix)