summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-27 23:58:07 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-27 23:58:07 +0200
commit208f7cd155abdf07ae4f858aeeb26892eb08df88 (patch)
treea6fc59bd1ae85e9f2929ee2079cc90539193e476 /guix/build-system
parent72d869634bd22d978af13f5a8c89ddff27140422 (diff)
downloadguix-patches-208f7cd155abdf07ae4f858aeeb26892eb08df88.tar
guix-patches-208f7cd155abdf07ae4f858aeeb26892eb08df88.tar.gz
Abstract build systems.
* Makefile.am (MODULES): Add `guix/build-system.scm' and `guix/build-system/gnu.scm'. Remove `guix/gnu-build-system.scm'. * guix/build-system.scm: New file. * guix/gnu-build-system.scm: Rename to... * guix/build-system/gnu.scm: ... this. (gnu-build-system): New variable. * tests/builders.scm: Adjust `use-module' clauses. ("gnu-build-system"): New test.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/gnu.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
new file mode 100644
index 0000000000..e9eb02f251
--- /dev/null
+++ b/guix/build-system/gnu.scm
@@ -0,0 +1,73 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build-system gnu)
+ #:use-module (guix store)
+ #:use-module (guix utils)
+ #:use-module (guix derivations)
+ #:use-module (guix build-system)
+ #:use-module (srfi srfi-1)
+ #:export (gnu-build
+ gnu-build-system))
+
+;; Commentary:
+;;
+;; Standard build procedure for packages using the GNU Build System or
+;; something compatible ("./configure && make && make install").
+;;
+;; Code:
+
+(define %standard-inputs
+ (map (lambda (name)
+ (list name (nixpkgs-derivation name)))
+ '("gnutar" "gzip" "bzip2" "xz" "diffutils" "patch"
+ "coreutils" "gnused" "gnugrep" "bash"
+ "gcc" "binutils" "gnumake" "glibc")))
+
+(define* (gnu-build store name source inputs
+ #:key (outputs '("out")) (configure-flags '())
+ (make-flags '()) (phases '%standard-phases)
+ (system (%current-system)))
+ "Return a derivation called NAME that builds from tarball SOURCE, with
+input derivation INPUTS, using the usual procedure of the GNU Build System."
+ (define builder
+ `(begin
+ (use-modules (guix build gnu-build-system))
+ (gnu-build #:source ,(if (derivation-path? source)
+ (derivation-path->output-path source)
+ source)
+ #:outputs %outputs
+ #:inputs %build-inputs
+ #:phases ,phases
+ #:configure-flags ',configure-flags
+ #:make-flags ',make-flags)))
+
+ (build-expression->derivation store name system
+ builder
+ `(("source" ,source)
+ ,@inputs
+ ,@%standard-inputs)
+ #:outputs outputs
+ #:modules '((guix build gnu-build-system)
+ (guix build utils))))
+
+(define gnu-build-system
+ (build-system (name 'gnu)
+ (description
+ "The GNU Build System—i.e., ./configure && make && make install")
+ (build gnu-build))) ; TODO: add `gnu-cross-build'