summaryrefslogtreecommitdiff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:06:27 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:06:27 +0100
commit03e856ddf5d28bc61144effb1a393b73cb4a2d9f (patch)
treef477e079cbdb4b274130e4fcb6c6a5acb781eedf /guix/build-system/python.scm
parent072f1e22cc6b1708fddedd1ac7ab12827284a785 (diff)
parent80983df357856fe4e65e384a655e466164e049a1 (diff)
downloadguix-patches-03e856ddf5d28bc61144effb1a393b73cb4a2d9f.tar
guix-patches-03e856ddf5d28bc61144effb1a393b73cb4a2d9f.tar.gz
Merge branch 'python-build-system'.
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index adeceb4a89..d4d3d28f2a 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -177,6 +177,7 @@ pre-defined variants."
#:key
(tests? #t)
(test-target "test")
+ (use-setuptools? #t)
(configure-flags ''())
(phases '(@ (guix build python-build-system)
%standard-phases))
@@ -204,6 +205,7 @@ provides a 'setup.py' file as its build system."
#:system ,system
#:test-target ,test-target
#:tests? ,tests?
+ #:use-setuptools? ,use-setuptools?
#:phases ,phases
#:outputs %outputs
#:search-paths ',(map search-path-specification->sexp