summaryrefslogtreecommitdiff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-23 22:30:10 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-23 22:30:10 +0100
commit53c85e97dcc264da5ff5cd4e3be4d47028f4d726 (patch)
tree8984fefeb61e0c165bf960fdfa3cd11355d02ba3 /guix/build-system/python.scm
parent2e838890ff989128e8a78eea574d1ad158dd6361 (diff)
parentc320011da5e743f47220f380c818e95394f6d9c0 (diff)
downloadguix-patches-53c85e97dcc264da5ff5cd4e3be4d47028f4d726.tar
guix-patches-53c85e97dcc264da5ff5cd4e3be4d47028f4d726.tar.gz
Merge branch 'core-updates'
Conflicts: gnu/packages/gnunet.scm
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index c5a2e86316..a97135fe0c 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -58,9 +58,8 @@ prepended to the name."
(let* ((build-system (package-build-system p))
(rewrite-if-package
(lambda (content)
- ;; CONTENT may be a string (e.g., for patches), in which case it
- ;; is returned, or a package, which is rewritten with the new
- ;; PYTHON and NEW-PREFIX.
+ ;; CONTENT may be a file name, in which case it is returned, or a
+ ;; package, which is rewritten with the new PYTHON and NEW-PREFIX.
(if (package? content)
(package-with-explicit-python content python
old-prefix new-prefix)