summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 10:04:33 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 10:43:26 +1000
commit5da4f84f1faa1caf9b1dbe599f53016acfcb4ff9 (patch)
tree84aaee2b81c39cc94fa20c28ec806d884533a703 /gnu
parentc0cab38e037e67e3b9c784270b846687b749b27f (diff)
downloadguix-patches-5da4f84f1faa1caf9b1dbe599f53016acfcb4ff9.tar
guix-patches-5da4f84f1faa1caf9b1dbe599f53016acfcb4ff9.tar.gz
gnu: Add r-trimcluster.
* gnu/packages/statistics.scm (r-trimcluster): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c9eddff259..16f647f852 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4325,3 +4325,23 @@ can be efficiently implemented directly in the R language.")
"This packages allows to analyze data with robust methods such as
regression methodology including model selections and multivariate statistics.")
(license license:gpl2+)))
+
+(define-public r-trimcluster
+ (package
+ (name "r-trimcluster")
+ (version "0.1-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "trimcluster" version))
+ (sha256
+ (base32
+ "0lsgbg93hm0w1rdb813ry0ks2l0jfpyqzqkf3h3bj6fch0avcbv2"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/trimcluster")
+ (synopsis "Cluster analysis with trimming")
+ (description
+ "The trimmed k-means clustering method by Cuesta-Albertos, Gordaliza and
+Matran (1997). This optimizes the k-means criterion under trimming a portion
+of the points.")
+ (license license:gpl2+)))