summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:27:10 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-03-14 22:09:41 +0100
commit14af90cfbd864aae8637f3046cf878c5dd4c8778 (patch)
tree7d323c8e0ae6ed8d55fae4827ed3be4b726ad272 /gnu
parent334436f051172bd5b2ad5afa003ff311580ce920 (diff)
downloadguix-patches-14af90cfbd864aae8637f3046cf878c5dd4c8778.tar
guix-patches-14af90cfbd864aae8637f3046cf878c5dd4c8778.tar.gz
gnu: Add ocaml-ppx-variants-conv.
* gnu/packages/ocaml.scm (ocaml-ppx-variants-conv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a46183ac01..63a7c082a3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2352,3 +2352,26 @@ s-expressions.")
(description "Generation of S-expression conversion functions from type
definitions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-variants-conv
+ (package
+ (name "ocaml-ppx-variants-conv")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_variants_conv" version
+ "0vnn2l1118cj72413d3f7frlw6yc09l8f64jlzkzbgb9bxpalx34"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-core" ,ocaml-ppx-core)
+ ("variantslib" ,ocaml-variantslib)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-type-conv" ,ocaml-ppx-type-conv)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_variants_conv")
+ (synopsis "Generation of accessor and iteration functions for ocaml variant
+types")
+ (description "Generation of accessor and iteration functions for ocaml
+variant types.")
+ (license license:asl2.0)))