summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-20 15:08:38 -0500
committerMark H Weaver <mhw@netris.org>2014-12-20 15:08:38 -0500
commit7dcf67c070b926274aaef3234edfb2ea77c24862 (patch)
tree2d626b2202769e73b7d1304f14953b625f14abc9 /gnu
parentd2611ffbb5a0de4efb8a48742e52a6e44e7f57d8 (diff)
parentce44657aab50dd4ab9bdb7570729fc99ee33275a (diff)
downloadguix-patches-7dcf67c070b926274aaef3234edfb2ea77c24862.tar
guix-patches-7dcf67c070b926274aaef3234edfb2ea77c24862.tar.gz
Merge branch 'master' into xorg-updates
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm57
-rw-r--r--gnu/packages/xfce.scm30
2 files changed, 86 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5d84f4e411..d9a22b41bb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -47,7 +47,8 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages compression)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages xdisorg))
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages ncurses))
(define-public brasero
(package
@@ -1324,3 +1325,57 @@ language features to GNOME developers without imposing any additional runtime
requirements and without using a different ABI compared to applications and
libraries written in C.")
(license license:lgpl2.1+)))
+
+(define-public vte
+ (package
+ (name "vte")
+ (version "0.38.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1rbxrigff9yszbgdw0gw4c2saz4d1hbbpz21phzxx14w49wvmnmj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("vala" ,vala)
+ ("gobject-introspection" ,gobject-introspection)
+ ("glib" ,glib "bin") ; for glib-genmarshal, etc.
+ ("xmllint" ,libxml2)))
+ (propagated-inputs
+ `(("gtk+" ,gtk+))) ; required by libvte-2.91.pc
+ (home-page "http://www.gnome.org/")
+ (synopsis "Virtual Terminal Emulator")
+ (description
+ "VTE is a library (libvte) implementing a terminal emulator widget for
+GTK+, and a minimal sample application (vte) using that. Vte is mainly used in
+gnome-terminal, but can also be used to embed a console/terminal in games,
+editors, IDEs, etc.")
+ (license license:lgpl2.1+)))
+
+;; stable version for gtk2, required by xfce4-terminal.
+(define-public vte/gtk+-2
+ (package (inherit vte)
+ (name "vte")
+ (version "0.28.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1bmhahkf8wdsra9whd3k5l5z4rv7r58ksr8mshzajgq2ma0hpkw6"))))
+ (arguments
+ '(#:configure-flags '("--disable-python")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("glib" ,glib "bin"))) ; for glib-genmarshal, etc.
+ (propagated-inputs
+ `(("gtk+" ,gtk+-2) ; required by libvte.pc
+ ("ncurses" ,ncurses))))) ; required by libvte.la
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index b2954ff083..2b15c3e35c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -512,3 +512,33 @@ on the screen.")
optional application menu or icons for minimized applications or launchers,
devices and folders.")
(license gpl2+)))
+
+(define-public xfce4-terminal
+ (package
+ (name "xfce4-terminal")
+ (version "0.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/apps/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "023y0lkfijifh05yz8grimxadqpi98mrivr00sl18nirq8b4fbwi"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("vte" ,vte/gtk+-2)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce terminal emulator")
+ (description
+ "A lightweight and easy to use terminal emulator for Xfce. Features
+include a simple configuration interface, the ability to use multiple tabs
+with terminals within a single window, the possibility to have a
+pseudo-transparent terminal background, and a compact mode (where both the
+menubar and the window decorations are hidden) that helps you to save space
+on your desktop.")
+ (license gpl2+)))