summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-24 20:44:04 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 15:15:44 +0100
commitf01a2dd80ac6a21177474a41d742e5a000225a4f (patch)
tree9f9915d069e94e1a07f6ccbcf6e6be3432bb5e3c /gnu
parente48e8fe8d58b6f694ae36bfbdacf989c78985831 (diff)
downloadguix-patches-f01a2dd80ac6a21177474a41d742e5a000225a4f.tar
guix-patches-f01a2dd80ac6a21177474a41d742e5a000225a4f.tar.gz
gnu: Add go-github-com-klauspost-cpuid-v2.
* gnu/packages/golang-xyz.scm (go-github-com-klauspost-cpuid-v2): New variable. Change-Id: I0465af816409325cd8b5b5f339c155d0326338a7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e814731b63..8eb47fbe9e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2179,6 +2179,24 @@ supported, and no external C (cgo) code is used, which should make the library
very eas to use.")
(license license:expat)))
+(define-public go-github-com-klauspost-cpuid-v2
+ (package
+ (inherit go-github-com-klauspost-cpuid )
+ (name "go-github-com-klauspost-cpuid-v2")
+ (version "2.2.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/cpuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fys5v9vslar483arj7wy4id5kg1c7vqv4437kgjnwvki69j9mxf"))))
+ (arguments
+ (list
+ #:import-path "github.com/klauspost/cpuid/v2"))))
+
(define-public go-github-com-lestrrat-go-envload
(package
(name "go-github-com-lestrrat-go-envload")