summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:18:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:26 +0100
commitc160d88c6cf65853a6c45a766fec188ccb31ffe2 (patch)
treeba8dd74d72046ae1dae20e47aabf8284e9a3b455 /gnu
parentbd7042bf31c7a6d6ab320ed70715f1938fe71a11 (diff)
downloadguix-patches-c160d88c6cf65853a6c45a766fec188ccb31ffe2.tar
guix-patches-c160d88c6cf65853a6c45a766fec188ccb31ffe2.tar.gz
gnu: go-github-com-chmduquesne-rollinghash: Enable all tests.
* gnu/packages/golang-crypto.scm (go-github-com-chmduquesne-rollinghash): Enable all tests. [arguments]: <#:phases>: Add custom 'check phase. [propagated-inputs]: Add go-code-cloudfoundry-org-bytefmt. Change-Id: I2cfe6b3d490de4b85ed0814e074caac1f73d6936
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index a0b8f24443..ddeb79badf 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -339,7 +339,18 @@ xxHash algorithm (XXH64).")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/chmduquesne/rollinghash/"))
+ #:import-path "github.com/chmduquesne/rollinghash/"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Run all tests, workaround for go-build-system's lack of Go
+ ;; modules support.
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (propagated-inputs
+ (list go-code-cloudfoundry-org-bytefmt))
(home-page "https://github.com/chmduquesne/rollinghash")
(synopsis "Rolling hashes in Go")
(description