summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 10:07:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:41 +0100
commitbae99a0c44bc3d7b5066d4a5392b1e7447560500 (patch)
treef9dd2a2f72966610f8bc32b89d4e010b9515bb90 /gnu
parent5a2a870a58bc5a8070765570cb44ad369394d8de (diff)
downloadguix-patches-bae99a0c44bc3d7b5066d4a5392b1e7447560500.tar
guix-patches-bae99a0c44bc3d7b5066d4a5392b1e7447560500.tar.gz
gnu: go-golang-org-x-sys: Enable tests.
* gnu/packages/golang-build.scm (go-golang-org-x-sys) [arguments]: <#:tests>: Enable them. <#:phases>: Add custom 'check phase. Change-Id: Ie58ea6f0aa677742307d18cfaafcf6ec381c85c9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 761e7e9d08..121a4ca49a 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -325,12 +325,16 @@ cancelation for groups of goroutines working on subtasks of a common task
(arguments
(list
#:import-path "golang.org/x/sys"
- ;; Source-only package
- #:tests? #f
#:phases
#~(modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(home-page "https://go.googlesource.com/sys")
(synopsis "Go support for low-level system interaction")
(description "This package provides supplemental libraries offering Go