summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-06-24 11:00:44 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-06-29 10:49:57 +0200
commita46908620fac09bd8ccd0f587a27e86035d3b1d7 (patch)
tree2d45cea1cc39bd874686993c5c27beb67eee5be9 /gnu
parent647524d308151ba2e73816616290b062a70eeea7 (diff)
downloadguix-patches-a46908620fac09bd8ccd0f587a27e86035d3b1d7.tar
guix-patches-a46908620fac09bd8ccd0f587a27e86035d3b1d7.tar.gz
gnu: stumpwm: Use a single output.
This is a warkaround for the excess library grafts issue that can prevent stumpwm from working properly. See <https://issues.guix.gnu.org/47115> and <https://issues.guix.gnu.org/62890>. * gnu/packages/wm.scm (stumpwm)[outputs]: Remove "lib" output. [arguments]: Remove references to the "lib" output from phases. (stumpwm+slynk, stumpwm-contrib, sbcl-stumpwm-pamixer, sbcl-stumpwm-ttf-fonts, sbcl-stumpwm-stumptray, sbcl-stumpwm-disk, sbcl-stumpwm-screenshot, sbcl-stumpwm-notify, sbcl-stumpwm-battery-portable)[inputs]: Replace '(stumpwm "lib")' with 'stumpwm'. Change-Id: I3d8f025057965032c40ea833d3ebe62f9700071d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm40
1 files changed, 14 insertions, 26 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 22ee09d780..505ce09c1a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2410,7 +2410,6 @@ wlr-output-management-unstable-v1 protocol.")
(list sbcl-alexandria
sbcl-cl-ppcre
sbcl-clx))
- (outputs '("out" "lib"))
(arguments
(list
#:phases
@@ -2423,12 +2422,12 @@ wlr-output-management-unstable-v1 protocol.")
(add-after 'create-asdf-configuration 'build-program
(lambda* (#:key outputs #:allow-other-keys)
(build-program
- (string-append (assoc-ref outputs "out") "/bin/stumpwm")
+ (string-append #$output "/bin/stumpwm")
outputs
#:entry-program '((stumpwm:stumpwm) 0))))
(add-after 'build-program 'create-desktop-file
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (let* ((out #$output)
(xsessions (string-append out "/share/xsessions")))
(mkdir-p xsessions)
(call-with-output-file
@@ -2445,7 +2444,7 @@ wlr-output-management-unstable-v1 protocol.")
out))))))
(add-after 'install 'install-manual
(lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (let* ((out #$output)
(info (string-append out "/share/info")))
(invoke "./autogen.sh")
(invoke "sh" "./configure" "SHELL=sh")
@@ -2453,8 +2452,7 @@ wlr-output-management-unstable-v1 protocol.")
(install-file "stumpwm.info" info))))
(add-after 'install-manual 'remove-temporary-cache
(lambda* (#:key outputs #:allow-other-keys)
- (delete-file-recursively (string-append (assoc-ref outputs "lib")
- "/.cache")))))))
+ (delete-file-recursively (string-append #$output "/.cache")))))))
(synopsis "Window manager written in Common Lisp")
(description
"Stumpwm is a window manager written entirely in Common Lisp.
@@ -2474,10 +2472,8 @@ productive, customizable lisp based systems.")
(package
(inherit stumpwm)
(name "stumpwm-with-slynk")
- (outputs '("out"))
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("slynk" ,sbcl-slynk)))
+ (list sbcl-slynk stumpwm))
(arguments
(substitute-keyword-arguments (package-arguments stumpwm)
((#:phases phases)
@@ -2492,8 +2488,7 @@ productive, customizable lisp based systems.")
#:dependencies '("stumpwm" "slynk")
#:dependency-prefixes
(map (lambda (input) (assoc-ref inputs input))
- '("stumpwm" "slynk")))
- #t)))
+ '("stumpwm" "sbcl-slynk"))))))
(delete 'copy-source)
(delete 'build)
(delete 'check)
@@ -2517,7 +2512,7 @@ productive, customizable lisp based systems.")
(base32 "1g8h2vd5qsmaiz6ixlx9ykrv6a08izmkf0js18fvljvznpyhsznz"))))
(build-system asdf-build-system/sbcl)
(inputs
- `(("stumpwm" ,stumpwm "lib")))
+ (list stumpwm))
(home-page "https://github.com/stumpwm/stumpwm-contrib")
(synopsis "StumpWM extra modules")
(description "This package provides extra modules for StumpWM.")
@@ -2562,7 +2557,7 @@ productive, customizable lisp based systems.")
(sha256
(base32
"0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))
- (inputs (list pamixer `(,stumpwm "lib")))
+ (inputs (list pamixer stumpwm))
(build-system asdf-build-system/sbcl)
(arguments
(list #:asd-systems ''("pamixer")
@@ -2604,8 +2599,7 @@ mouse control mode for StumpWM.")
(inherit stumpwm-contrib)
(name "sbcl-stumpwm-ttf-fonts")
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("clx-truetype" ,sbcl-clx-truetype)))
+ (list sbcl-clx-truetype stumpwm))
(arguments
'(#:asd-systems '("ttf-fonts")
#:tests? #f
@@ -2717,9 +2711,7 @@ between windows.")
(modify-phases %standard-phases
(add-after 'unpack 'chdir (lambda _ (chdir "modeline/stumptray") #t)))))
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("xembed" ,sbcl-clx-xembed)
- ("alexandria" ,sbcl-alexandria)))
+ (list sbcl-alexandria sbcl-clx-xembed stumpwm))
(home-page
"https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/stumptray")
(synopsis "Modeline support for stumptray connectivity")
@@ -2794,9 +2786,7 @@ layouts in StumpWM.")
(add-after 'unpack 'chdir
(lambda _ (chdir "modeline/disk") #t)))))
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("cl-diskspace" ,sbcl-cl-diskspace)
- ("cl-mount-info" ,sbcl-cl-mount-info)))
+ (list sbcl-cl-diskspace sbcl-cl-mount-info stumpwm))
(home-page "https://github.com/stumpwm/stumpwm-contrib")
(synopsis "StumpWM modeline support to show disk usage")
(description "StumpWM modeline support to show disk usage")
@@ -2844,8 +2834,7 @@ one in Emacs.")
(inherit stumpwm-contrib)
(name "sbcl-stumpwm-screenshot")
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("zpng" ,sbcl-zpng)))
+ (list sbcl-zpng stumpwm))
(arguments
'(#:asd-systems '("screenshot")
#:tests? #f
@@ -2894,7 +2883,7 @@ modeline.")
(list sbcl-bordeaux-threads
sbcl-dbus
sbcl-xml-emitter
- (list stumpwm "lib")))
+ stumpwm))
(arguments
'(#:asd-systems '("notify")
#:phases
@@ -2914,8 +2903,7 @@ by default.")
(name "sbcl-stumpwm-battery-portable")
(build-system asdf-build-system/sbcl)
(inputs
- (list sbcl-cl-ppcre
- (list stumpwm "lib")))
+ (list sbcl-cl-ppcre stumpwm))
(arguments
'(#:asd-systems '("battery-portable")
#:phases