summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 17:11:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 11:31:45 +0100
commit8cf6d2832931f4f3a7138c453b25e8e133560a45 (patch)
tree488a4468ff9e0d2781a76581707124a4cdc20661 /gnu
parentf9a3d7a3d76d2d67e3470a9b5ffa0717f2170bd9 (diff)
downloadguix-patches-8cf6d2832931f4f3a7138c453b25e8e133560a45.tar
guix-patches-8cf6d2832931f4f3a7138c453b25e8e133560a45.tar.gz
gnu: go-github-com-masterminds-sprig: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-masterminds-sprig): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I424ea6887286bdaee67b3f367024c6d7982bcbd2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm37
-rw-r--r--gnu/packages/golang.scm34
2 files changed, 37 insertions, 34 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 38fa1ea868..4df7c31c80 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2343,6 +2343,43 @@ implementing features like:
@end itemize")
(license license:expat))))
+(define-public go-github-com-masterminds-sprig
+ (package
+ (name "go-github-com-masterminds-sprig")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Masterminds/sprig")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wwi8n2adjc5jlga25lqq0hrz4jcgd5vpll68y2dfji034caaq18"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ;network tests only
+ #:import-path "github.com/Masterminds/sprig"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-google-uuid
+ go-github-com-huandu-xstrings
+ go-github-com-imdario-mergo
+ go-github-com-masterminds-goutils
+ go-github-com-masterminds-semver
+ go-github-com-mitchellh-copystructure
+ go-github-com-mitchellh-reflectwalk
+ go-github-com-spf13-cast
+ go-golang-org-x-crypto))
+ (home-page "https://github.com/Masterminds/sprig/")
+ (synopsis "Template functions for Go templates")
+ (description
+ "Sprig is a library that provides more than 100 commonly used template
+functions.")
+ (license license:expat)))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4e3fe5bd10..9618d33e29 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6804,40 +6804,6 @@ maps (because they are not addressable using Go reflection).")
(native-inputs
(list go-gopkg-in-yaml-v3))))
-(define-public go-github-com-masterminds-sprig
- (package
- (name "go-github-com-masterminds-sprig")
- (version "3.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Masterminds/sprig")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wwi8n2adjc5jlga25lqq0hrz4jcgd5vpll68y2dfji034caaq18"))))
- (build-system go-build-system)
- (arguments
- `(#:tests? #f ;network tests only
- #:import-path "github.com/Masterminds/sprig"))
- (native-inputs
- (list go-github-com-masterminds-goutils
- go-github-com-masterminds-semver
- go-github-com-google-uuid
- go-github-com-huandu-xstrings
- go-github-com-imdario-mergo
- go-github-com-mitchellh-reflectwalk
- go-github-com-mitchellh-copystructure
- go-github-com-spf13-cast
- go-golang-org-x-crypto
- go-github-com-stretchr-testify))
- (home-page "https://github.com/Masterminds/sprig/")
- (synopsis "Template functions for Go templates")
- (description "Sprig is a library that provides more than 100 commonly used
-template functions.")
- (license license:expat)))
-
(define-public go-github-com-bmatcuk-doublestar
(package
(name "go-github-com-bmatcuk-doublestar")