summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-22 09:43:27 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:35:58 +0100
commit85df67d365e710c19a57415a5db6ac08aefb39b3 (patch)
treecefe93dfd5ec35a232b2c812fe30f5a9c5048d89 /gnu
parent0fe4e6425ed2d920f2577c2fb9bebdad38afac05 (diff)
downloadguix-patches-85df67d365e710c19a57415a5db6ac08aefb39b3.tar
guix-patches-85df67d365e710c19a57415a5db6ac08aefb39b3.tar.gz
gnu: Add go-go-etcd-io-gofail.
* gnu/packages/golang-check.scm (go-go-etcd-io-gofail): New variable. Change-Id: I86478db4267cd8559c1d87497f1b635ffe86192d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index aa60512bfb..f886b66c9f 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -956,6 +956,37 @@ makes extraction of setup/teardown behavior (as well as invoking the system
under test) much simpler.")
(license license:expat)))
+(define-public go-go-etcd-io-gofail
+ (package
+ (name "go-go-etcd-io-gofail")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/etcd-io/gofail")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jh0qjgfb2irshwj7an3lj0w9bv6c5gbnkdhisgpdr7x7hk682m1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "go.etcd.io/gofail"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://pkg.go.dev/go.etcd.io/gofail")
+ (synopsis "Failpoints for go")
+ (description
+ "This package provides an implementation of
+@url{http://www.freebsd.org/cgi/man.cgi?query=fail,failpoints} for Golang.")
+ (license license:asl2.0)))
+
(define-public go-golang-org-sql-mock
(let ((commit "e98392b8111b45f8126e00af035a0dd95dc12e8b")
(version "1.3.3")