summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 17:47:39 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 14:57:07 +0100
commit77ec077071910b51ac71e1fc4dd7be24f0a7b615 (patch)
tree3b295ef58ecdd11833398377d9a6befc91a2f643 /gnu
parentaa32bdfa78a3b0228528c5833d0d29471a37b7b8 (diff)
downloadguix-patches-77ec077071910b51ac71e1fc4dd7be24f0a7b615.tar
guix-patches-77ec077071910b51ac71e1fc4dd7be24f0a7b615.tar.gz
gnu: chezmoi: Refresh package style.
* gnu/packages/configuration-management.scm (chezmoi): Use G-expressions and list style, re-indent. [arguments]: <#:go>: Set to go-1.21. Change-Id: I5a7a4deffcd8b9102614b3f628a7ddd33ee82633
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/configuration-management.scm68
1 files changed, 36 insertions, 32 deletions
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index c8d38afa2b..c061684a6a 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,7 @@
(define-module (gnu packages configuration-management)
#:use-module (gnu packages)
#:use-module (guix build-system go)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
@@ -45,38 +47,40 @@
"0ildvlq7v8vnw74y4fgnv3hpq49bpl6zh1wmakfh46crwg7ffmjb"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/twpayne/chezmoi"
- #:install-source? #f
- #:phases
- (modify-phases %standard-phases
- ;; Remove test script which expect additional user's programs available
- ;; in the PATH. The testdata directory is removed in the latest version
- ;; (2.46.1) of the program.
- (add-after 'unpack 'remove-failing-test-scripts
- (lambda* (#:key import-path #:allow-other-keys)
- (for-each (lambda (f)
- (delete-file (string-append "src/" import-path "/testdata/scripts/" f)))
- '("bitwarden.txt"
- "cd.txt"
- "cd_unix.txt"
- "completion.txt"
- "diff.txt"
- "edit.txt"
- "editconfig.txt"
- "git.txt"
- "gopass.txt"
- "keepassxc.txt"
- "lastpass.txt"
- "onepassword.txt"
- "pass.txt"
- "runscriptdir_unix.txt"
- "script_unix.txt"
- "secretgeneric.txt"
- "secretgopass.txt"
- "secretkeepassxc.txt"
- "secretlastpass.txt"
- "secretonepassword.txt"
- "secretpass.txt")))))))
+ (list
+ #:go go-1.21
+ #:import-path "github.com/twpayne/chezmoi"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Remove test script which expect additional user's programs available
+ ;; in the PATH. The testdata directory is removed in the latest version
+ ;; (2.46.1) of the program.
+ (add-after 'unpack 'remove-failing-test-scripts
+ (lambda* (#:key import-path #:allow-other-keys)
+ (for-each (lambda (f)
+ (delete-file (string-append "src/" import-path "/testdata/scripts/" f)))
+ '("bitwarden.txt"
+ "cd.txt"
+ "cd_unix.txt"
+ "completion.txt"
+ "diff.txt"
+ "edit.txt"
+ "editconfig.txt"
+ "git.txt"
+ "gopass.txt"
+ "keepassxc.txt"
+ "lastpass.txt"
+ "onepassword.txt"
+ "pass.txt"
+ "runscriptdir_unix.txt"
+ "script_unix.txt"
+ "secretgeneric.txt"
+ "secretgopass.txt"
+ "secretkeepassxc.txt"
+ "secretlastpass.txt"
+ "secretonepassword.txt"
+ "secretpass.txt")))))))
(native-inputs
(list go-etcd-io-bbolt
go-github-com-alecthomas-chroma