summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 17:45:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 15:15:43 +0100
commit6fed47ad941808c855705f8fa7da37c52d686482 (patch)
treec334c4405caccd71ddaac76bf14fc16bc70fafcf /gnu
parent6d6a344a08c7d0b7c4c08f8344e2152137677ccc (diff)
downloadguix-patches-6fed47ad941808c855705f8fa7da37c52d686482.tar
guix-patches-6fed47ad941808c855705f8fa7da37c52d686482.tar.gz
gnu: go-github-com-masterminds-semver-v3: Update to 3.2.1.
* gnu/packages/golang-xyz.scm (go-github-com-masterminds-semver-v3): Update to 3.2.1. [native-inputs]: Add go-github-com-stretchr-testify-next. Change-Id: I6313394293de4d953a1ef344701d117eab35d237
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4d801c2b1a..2906e7ffff 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2346,7 +2346,7 @@ implementing features like:
(define-public go-github-com-masterminds-semver-v3
(package
(name "go-github-com-masterminds-semver-v3")
- (version "3.1.0")
+ (version "3.2.1")
(source
(origin
(method git-fetch)
@@ -2355,11 +2355,14 @@ implementing features like:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g1wizfdy29d02l9dh8gsb029yr4m4swp13swf0pnh9ryh5f1msz"))))
+ (base32 "1h4c647dgq6k5q78j3m98ccdrzd7kbcq4ahdy25j72rbxjmci8al"))))
(build-system go-build-system)
(arguments
(list
+ #:go go-1.21
#:import-path "github.com/Masterminds/semver/v3"))
+ (native-inputs
+ (list go-github-com-stretchr-testify-next))
(home-page "https://github.com/Masterminds/semver/")
(synopsis "@code{semver} helps to work with semantic versions")
(description