summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 17:36:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 15:15:43 +0100
commit6d6a344a08c7d0b7c4c08f8344e2152137677ccc (patch)
tree57f1a1c5228ab2b85ee7833f672c500bde9395d1 /gnu
parent1526c615bcfa90e64bd5536d533db23cffed6382 (diff)
downloadguix-patches-6d6a344a08c7d0b7c4c08f8344e2152137677ccc.tar
guix-patches-6d6a344a08c7d0b7c4c08f8344e2152137677ccc.tar.gz
gnu: go-github-com-masterminds-semver: Rename variable.
* gnu/packages/golang-xyz.scm (go-github-com-masterminds-semver): Rename to go-github-com-masterminds-semver-v3. [arguments]: <#:import-path>: Reflect import path as seen in go.mod. * gnu/packages/golang-xyz.scm (go-github-com-masterminds-sprig) [propagated-inputs]: Replace go-github-com-masterminds-semver with go-github-com-masterminds-semver-v3. Change-Id: I43f2231241f02b6f2f01f89f98a72f29929b9376
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c0e2c24906..4d801c2b1a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2343,9 +2343,9 @@ implementing features like:
@end itemize")
(license license:expat))))
-(define-public go-github-com-masterminds-semver
+(define-public go-github-com-masterminds-semver-v3
(package
- (name "go-github-com-masterminds-semver")
+ (name "go-github-com-masterminds-semver-v3")
(version "3.1.0")
(source
(origin
@@ -2359,7 +2359,7 @@ implementing features like:
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/Masterminds/semver"))
+ #:import-path "github.com/Masterminds/semver/v3"))
(home-page "https://github.com/Masterminds/semver/")
(synopsis "@code{semver} helps to work with semantic versions")
(description
@@ -2405,7 +2405,7 @@ semantic versions. Specifically it provides the ability to:
go-github-com-huandu-xstrings
go-github-com-imdario-mergo
go-github-com-masterminds-goutils
- go-github-com-masterminds-semver
+ go-github-com-masterminds-semver-v3
go-github-com-mitchellh-copystructure
go-github-com-mitchellh-reflectwalk
go-github-com-spf13-cast