summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 09:24:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:41 +0100
commit5a2a870a58bc5a8070765570cb44ad369394d8de (patch)
treeb0152ae0802ad32fcefe6508de98c026e58a956e /gnu
parent7e300af164d6abd8c6c203eda9d3d705e94390bc (diff)
downloadguix-patches-5a2a870a58bc5a8070765570cb44ad369394d8de.tar
guix-patches-5a2a870a58bc5a8070765570cb44ad369394d8de.tar.gz
gnu: go-golang-org-x-sync: Improve description.
* gnu/packages/golang-build.scm (go-golang-org-x-sync) [description]: Extend and improve description. Change-Id: Ie5b48230d7bc7bbd03e2af76d3a3660960282291
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 9c56c38fd9..761e7e9d08 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -293,9 +293,17 @@ loading algorithms.")
(invoke "go" "test" "-v" "./..."))))))))
(home-page "https://go.googlesource.com/sync/")
(synopsis "Additional Go concurrency primitives")
- (description "This package provides Go concurrency primitives in
-addition to the ones provided by the language and “sync” and “sync/atomic”
-packages.")
+ (description
+ "This package provides Go concurrency primitives in addition to the ones
+provided by the language and @code{sync} and @code{sync/atomic} packages.
+The package provides several Golang submodules:
+@itemize
+@item @code{errgroup} - synchronization, error propagation, and Context
+cancelation for groups of goroutines working on subtasks of a common task
+@item @code{semaphore} - a weighted semaphore implementation
+@item @code{singleflight} - a duplicate function call suppression mechanism
+@item @code{syncmap} - a concurrent map implementation
+@end itemize")
(license license:bsd-3)))
(define-public go-golang-org-x-sys