summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 17:34:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 15:15:43 +0100
commit1526c615bcfa90e64bd5536d533db23cffed6382 (patch)
tree1ac7a148323662cfe1a99371ff2b0cd302bccd7f /gnu
parentd9f720b7ef34934f8964c1a3879b5aab3a09bbd1 (diff)
downloadguix-patches-1526c615bcfa90e64bd5536d533db23cffed6382.tar
guix-patches-1526c615bcfa90e64bd5536d533db23cffed6382.tar.gz
gnu: go-github-com-masterminds-semver: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-masterminds-semver): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I267210f30143c29fe1927e7fbf9ae8cdff633092
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm30
-rw-r--r--gnu/packages/golang.scm28
2 files changed, 30 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ca48d5ed6c..c0e2c24906 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2343,6 +2343,36 @@ implementing features like:
@end itemize")
(license license:expat))))
+(define-public go-github-com-masterminds-semver
+ (package
+ (name "go-github-com-masterminds-semver")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Masterminds/semver")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g1wizfdy29d02l9dh8gsb029yr4m4swp13swf0pnh9ryh5f1msz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/Masterminds/semver"))
+ (home-page "https://github.com/Masterminds/semver/")
+ (synopsis "@code{semver} helps to work with semantic versions")
+ (description
+ "The semver package provides the ability to work with
+semantic versions. Specifically it provides the ability to:
+@itemize
+@item Parse semantic versions
+@item Sort semantic versions
+@item Check if a semantic version fits within a set of constraints
+@item Optionally work with a @code{v} prefix
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-masterminds-sprig-v3
(package
(name "go-github-com-masterminds-sprig-v3")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9618d33e29..0e95691d1f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6704,34 +6704,6 @@ various ways. It is a Go implementation of some string manipulation libraries
of Java Apache Commons.")
(license license:asl2.0)))
-(define-public go-github-com-masterminds-semver
- (package
- (name "go-github-com-masterminds-semver")
- (version "3.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Masterminds/semver")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1g1wizfdy29d02l9dh8gsb029yr4m4swp13swf0pnh9ryh5f1msz"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/Masterminds/semver"))
- (home-page "https://github.com/Masterminds/semver/")
- (synopsis "@code{semver} helps to work with semantic versions")
- (description "The semver package provides the ability to work with
-semantic versions. Specifically it provides the ability to:
-@itemize
-@item Parse semantic versions
-@item Sort semantic versions
-@item Check if a semantic version fits within a set of constraints
-@item Optionally work with a @code{v} prefix
-@end itemize\n")
- (license license:expat)))
-
(define-public go-github-com-huandu-xstrings
(package
(name "go-github-com-huandu-xstrings")