summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-06-17 22:52:32 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-06-24 08:50:49 -0400
commitcd15d417e30597b131aa00cea0aaa78a36cc74a6 (patch)
tree4ace83142556049052838bcc4d058906d4e5121f /gnu
parent0fe46e53bbd7e190c3e757fb842cd3e45e73f4e8 (diff)
downloadguix-patches-cd15d417e30597b131aa00cea0aaa78a36cc74a6.tar
guix-patches-cd15d417e30597b131aa00cea0aaa78a36cc74a6.tar.gz
gnu: nginx: Update to 1.27.0.
* gnu/packages/web.scm (nginx): Update to 1.27.0. (nginx-documentation): Update to 1.27.0. (nginx-accept-language-module)[arguments]: Add configure flags to enable compatibility and fix build. Change-Id: I447e0bb8677d3f3b14c3a8948c625bcad437ca73 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 38f86c4d33..7f9c63ad18 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -510,14 +510,14 @@ the same, being completely separated from the Internet.")
;; Track the ‘mainline’ branch. Upstream considers it more reliable than
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
- (version "1.23.3")
+ (version "1.27.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "0m5s8a04jlpv6qhk09sfqbj4rxj38g6923w12j5y3ymrvf3mgjvm"))))
+ "170ja338zh7wdyva34cr7f3wfq59434sssn51d5jvakyz0y0w8xp"))))
(build-system gnu-build-system)
(inputs (list libxml2 libxslt openssl pcre zlib))
(arguments
@@ -607,9 +607,9 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.23.3")
- (revision 2916)
- (changeset "178f55cf631a"))
+ (let ((version "1.27.0")
+ (revision 3081)
+ (changeset "1b23e39a3b94"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -621,7 +621,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(file-name (string-append name "-" version))
(sha256
(base32
- "0b03dnniwm3p3gd76vqs6lj2z4blqmb7y4lhn9vg7xjz0yqgzvn2"))))
+ "0xnfda8xh8mv00fsycqbwicm8bb7rsvdqmmwv0h372kiwxnazjkh"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -631,7 +631,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))
- (substitute* "umasked.sh"
+ (substitute* "tools/umasked.sh"
((" /bin/sh") (string-append " " (which "sh"))))
;; The documentation includes a banner, which makes sense on
;; the NGinx website, but doesn't make much sense when
@@ -733,6 +733,7 @@ ngx_http_accept_language_module~%")
"--with-http_v2_module"
"--with-pcre-jit"
"--with-debug"
+ "--with-compat"
;; Even when not cross-building, we pass the
;; --crossbuild option to avoid customizing for the
;; kernel version on the build machine.