summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-11-18 14:28:13 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:03:15 +0100
commit09c44196e10e7f619715fcc2beb7a1e67239638e (patch)
tree1640212bba2a09c15553494ff3b6e984e5c588e4 /gnu
parent04162e83ff1f1943f49504038c08a9166eefd311 (diff)
downloadguix-patches-09c44196e10e7f619715fcc2beb7a1e67239638e.tar
guix-patches-09c44196e10e7f619715fcc2beb7a1e67239638e.tar.gz
gnu: Add java-gson.
* gnu/packages/java.scm (java-gson): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e2a0f75f76..20d32bdf1f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7761,3 +7761,30 @@ outputting XML data from Java code.")
(description "Xbean-reflect provides very flexible ways to create objects
and graphs of objects for dependency injection frameworks")
(license license:asl2.0)))
+
+(define-public java-gson
+ (package
+ (name "java-gson")
+ (version "2.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/gson/archive/"
+ "gson-parent-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j4qnp7v046q0k48c4kyf69sxaasx2h949d3cqwsm3kzxms3x0f9"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "gson.jar"
+ #:source-dir "gson/src/main/java"
+ #:test-dir "gson/src/test"))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)))
+ (home-page "https://github.com/google/gson")
+ (synopsis "Java serialization/deserialization library from/to JSON")
+ (description "Gson is a Java library that can be used to convert Java
+Objects into their JSON representation. It can also be used to convert a JSON
+string to an equivalent Java object. Gson can work with arbitrary Java objects
+including pre-existing objects that you do not have source-code of.")
+ (license license:asl2.0)))