summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrit Butler via Guix-patches via <guix-patches@gnu.org>2021-01-12 03:58:13 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-12 09:48:37 +0100
commit10f75456af57ca87008859f83acdcbf754f6c14b (patch)
tree4779af7a2fa7fbeb3ca2b07013bc1a3c5ebf4a16 /gnu
parent18c624977373020878b59efcc8de0171e759b431 (diff)
downloadguix-patches-10f75456af57ca87008859f83acdcbf754f6c14b.tar
guix-patches-10f75456af57ca87008859f83acdcbf754f6c14b.tar.gz
gnu: Add emacs-marginalia.
* gnu/packages/emacs-xyz.scm (emacs-marginalia): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 379a6bb57b..f801bac509 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7039,6 +7039,33 @@ Emacs completion function completing-read, which allows to quickly select from a
list of candidates.")
(license license:gpl3+))))
+(define-public emacs-marginalia
+ ;; There are no tagged releases upstream on GitHub, instead we are using the
+ ;; most recent commit.
+ (let ((commit "401993562dbf636054dd64988e44d19b5030867f")
+ (revision "0"))
+ (package
+ (name "emacs-marginalia")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/marginalia")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j0k9ija5paidj7yvbagkkayz9bjwhia9yhmd2q4490ginbbxshs"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/marginalia")
+ (synopsis "Marginalia in the minibuffer")
+ (description
+ "This package provides Marginalia mode which adds marginalia to the
+minibuffer completions. Marginalia are marks or annotations placed at the
+margin of the page of a book or in this case helpful colorful annotations
+placed at the margin of the minibuffer for your completion candidates.")
+ (license license:gpl3+))))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")