summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:13:39 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:20 +0200
commitfee9b2662ed625432a6ed09e481fb436ebe335e9 (patch)
treec3d48c298a248aeba34163c9a296225bcff24d0a /gnu
parent979e18fa9d6cc62c5928c72a58999cdfd2561430 (diff)
downloadguix-patches-fee9b2662ed625432a6ed09e481fb436ebe335e9.tar
guix-patches-fee9b2662ed625432a6ed09e481fb436ebe335e9.tar.gz
gnu: Add kpty.
* gnu/packages/kde-frameworks.scm (kpty): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index eed6fffd96..36097cc267 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1369,3 +1369,40 @@ covers feedback and persistent events.")
of non binary content such as scripted extensions or graphic assets, as if they
were traditional plugins.")
(license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public kpty
+ (package
+ (name "kpty")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1ybvdzqpa53kkki9p5da0ff9x3c63rmksk7865wqwlgy8apzi2fs"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:tests? #f ; FIXME: 1/1 tests fail.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+ (substitute* "autotests/kptyprocesstest.cpp"
+ (("/bin/bash") (which "bash")))
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Interfacing with pseudo terminal devices")
+ (description "This library provides primitives to interface with pseudo
+terminal devices as well as a KProcess derived class for running child processes
+and communicating with them using a pty.")
+ (license (list license:gpl2+ license:lgpl2.1+))))