summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-05-10 19:27:25 +0800
committerLudovic Courtès <ludo@gnu.org>2022-05-20 20:23:17 +0200
commitfd94ccf8f185f6439905f23bbb46e5f85d87fd3a (patch)
tree450f8e675a8e7315befe1109d1940522f975ff32 /gnu
parentbe21ae6861c879509e14672437a3788899030340 (diff)
downloadguix-patches-fd94ccf8f185f6439905f23bbb46e5f85d87fd3a.tar
guix-patches-fd94ccf8f185f6439905f23bbb46e5f85d87fd3a.tar.gz
gnu: clang: Add OBJC_INCLUDE_PATH to native-search-paths.
Clang is also a compiler for Objective-C. * gnu/packages/llvm.scm (clang-for-llvm): Add OBJC_INCLUDE_PATH to native-search-paths. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index b84d987dbb..4d5a948236 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -389,6 +389,9 @@ given PATCHES. When TOOLS-EXTRA is given, it must point to the
(variable "CPLUS_INCLUDE_PATH")
(files '("include/c++" "include")))
(search-path-specification
+ (variable "OBJC_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))