summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-05 15:02:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-05 15:04:15 +0100
commitf5c3e8e2ec9ab9e105c0b53afa0c2f5d5fa11065 (patch)
tree309b48e2bde2fdb3f18910919be081d24de59d79 /gnu
parentc0c3f7466c733ba8abcde9cc3bd436f435faaf33 (diff)
downloadguix-patches-f5c3e8e2ec9ab9e105c0b53afa0c2f5d5fa11065.tar
guix-patches-f5c3e8e2ec9ab9e105c0b53afa0c2f5d5fa11065.tar.gz
gnu: Add r-cellchat.
* gnu/packages/bioinformatics.scm (r-cellchat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d617736e57..6d21e14360 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10859,6 +10859,72 @@ explore and perform basic analysis of single cell sequencing data coming from
droplet sequencing. It has been particularly tailored for Drop-seq.")
(license license:gpl3))))
+(define-public r-cellchat
+ (let ((commit
+ "21edd226ca408e4c413408f98562d71ee0b54e5d")
+ (revision "1"))
+ (package
+ (name "r-cellchat")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sqjin/CellChat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cvzl9mi8jjznpql2gv67swnk1dndn3a2h22z5l84h7lwpwjmh53"))
+ (snippet
+ '(for-each delete-file '("src/CellChat.so"
+ "src/CellChat_Rcpp.o"
+ "src/RcppExports.o")))))
+ (properties `((upstream-name . "CellChat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-circlize" ,r-circlize)
+ ("r-colorspace" ,r-colorspace)
+ ("r-complexheatmap" ,r-complexheatmap)
+ ("r-cowplot" ,r-cowplot)
+ ("r-dplyr" ,r-dplyr)
+ ("r-expm" ,r-expm)
+ ("r-fnn" ,r-fnn)
+ ("r-forcats" ,r-forcats)
+ ("r-future" ,r-future)
+ ("r-future-apply" ,r-future-apply)
+ ("r-gg-gap" ,r-gg-gap)
+ ("r-ggalluvial" ,r-ggalluvial)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-igraph" ,r-igraph)
+ ("r-irlba" ,r-irlba)
+ ("r-magrittr" ,r-magrittr)
+ ("r-matrix" ,r-matrix)
+ ("r-nmf" ,r-nmf)
+ ("r-patchwork" ,r-patchwork)
+ ("r-pbapply" ,r-pbapply)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcppeigen" ,r-rcppeigen)
+ ("r-reshape2" ,r-reshape2)
+ ("r-reticulate" ,r-reticulate)
+ ("r-rspectra" ,r-rspectra)
+ ("r-rtsne" ,r-rtsne)
+ ("r-scales" ,r-scales)
+ ("r-shape" ,r-shape)
+ ("r-sna" ,r-sna)
+ ("r-stringr" ,r-stringr)
+ ("r-svglite" ,r-svglite)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/sqjin/CellChat")
+ (synopsis "Analysis of cell-cell communication from single-cell transcriptomics data")
+ (description
+ "This package infers, visualizes and analyzes the cell-cell
+communication networks from scRNA-seq data.")
+ (license license:gpl3))))
+
(define-public sambamba
(package
(name "sambamba")