summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-22 23:00:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-22 23:00:40 +0300
commite06eeaa4caa6181dc9f13e3f75b1d762669801b8 (patch)
tree53b4784c31fca838d1384377bb29d1ad1c8fc242 /gnu
parent8621ff6bd58033a556c4dbd464b5c697445df8d0 (diff)
downloadguix-patches-e06eeaa4caa6181dc9f13e3f75b1d762669801b8.tar
guix-patches-e06eeaa4caa6181dc9f13e3f75b1d762669801b8.tar.gz
gnu: python-sympy: Update check phase.
* gnu/packages/python-xyz.scm (python-sympy)[arguments]: Replace 'check phase instead of deleting it and adding it back in.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b1a2ab5efd..af557fd009 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7590,16 +7590,11 @@ multiprecision arithmetic.")
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Run the core tests after installation. By default it would run
- ;; *all* tests, which take a very long time to complete and are known
- ;; to be flaky.
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key outputs #:allow-other-keys)
(invoke
(or (which "python3") (which "python"))
- "-c" "import sympy; sympy.test(\"/core\")")
- #t)))))
+ "-c" "import sympy; sympy.test(\"/core\")"))))))
(propagated-inputs
`(("python-mpmath" ,python-mpmath)))
(home-page "https://www.sympy.org/")