summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-03 23:48:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-03 23:48:46 +0100
commitdd19c8da88cb53689c91fd874739a86b31b76a13 (patch)
treecb2133ad76ccfd77c2c96e612b210f30ad926658 /gnu
parent0e09065460b2f0f5f20ea8a157605b2686bbe499 (diff)
downloadguix-patches-dd19c8da88cb53689c91fd874739a86b31b76a13.tar
guix-patches-dd19c8da88cb53689c91fd874739a86b31b76a13.tar.gz
gnu: bless: Remove trailing #T from snippet and build phases.
* gnu/packages/bioinformatics.scm (bless)[source, arguments]: Remove all trailing #Ts.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 94cad55483..e23f3f33fa 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1914,8 +1914,7 @@ confidence to have in an alignment.")
(delete-file-recursively "pigz")
(delete-file-recursively "google-sparsehash")
(delete-file-recursively "zlib")
- (delete-file-recursively ".git")
- #t))))
+ (delete-file-recursively ".git")))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;no "check" target
@@ -1934,8 +1933,7 @@ confidence to have in an alignment.")
(add-after 'unpack 'do-not-build-bundled-pigz
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "Makefile"
- (("cd pigz/pigz-2.3.3; make") ""))
- #t))
+ (("cd pigz/pigz-2.3.3; make") ""))))
(add-after 'unpack 'patch-paths-to-executables
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "parse_args.cpp"
@@ -1946,15 +1944,13 @@ confidence to have in an alignment.")
(("pigz_binary = .*")
(string-append "pigz_binary = \""
(assoc-ref inputs "pigz")
- "/bin/pigz\";")))
- #t))
+ "/bin/pigz\";")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
(for-each (lambda (file)
(install-file file bin))
- '("bless" "kmc/bin/kmc"))
- #t)))
+ '("bless" "kmc/bin/kmc")))))
(delete 'configure))))
(native-inputs
`(("perl" ,perl)))