summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-04 22:01:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-04 22:39:46 +0100
commitd4c4348d83e774017dce5b6163a05689a280f733 (patch)
treefe8840567e27c967a22d876343a92002422299a8 /gnu
parent3f03f502ee612adfcb41c7e849b2a79eb5e949d3 (diff)
downloadguix-patches-d4c4348d83e774017dce5b6163a05689a280f733.tar
guix-patches-d4c4348d83e774017dce5b6163a05689a280f733.tar.gz
gnu: gtranslator: Fix compilation.
* gnu/packages/gnome.scm (gtranslator)[inputs]: Replace LIBSOUP with LIBSOUP-MINIMAL-2. [arguments]: Pass #:meson.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1685470ced..3acb3e746c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12799,7 +12799,7 @@ your data.")
("gspell" ,gspell)
("libdazzle" ,libdazzle)
("libgda" ,libgda)
- ("libsoup" ,libsoup)))
+ ("libsoup" ,libsoup-minimal-2)))
(native-inputs
`(("glib:bin" ,glib "bin")
("itstool" ,itstool)
@@ -12807,7 +12807,8 @@ your data.")
(propagated-inputs
`(("gtksourceview" ,gtksourceview))) ; required for source view
(arguments
- `(#:build-type "release"
+ `(#:meson ,meson-0.59
+ #:build-type "release"
#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases