summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-10-03 19:45:06 +0200
committerAndreas Enge <andreas@enge.fr>2015-10-03 19:45:23 +0200
commitcfa2e4ad4097947ec393888dc4a95322e1364ba9 (patch)
tree4ad5f8d5cdf4bcdc9cc314e78341347f0e19232d /gnu
parentc9f6938033eaa4ed4b0a4b8209342ea9de839afc (diff)
downloadguix-patches-cfa2e4ad4097947ec393888dc4a95322e1364ba9.tar
guix-patches-cfa2e4ad4097947ec393888dc4a95322e1364ba9.tar.gz
gnu: Add lxqt-common.
* gnu/packages/lxqt.scm (lxqt-common): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 064f8c4f81..518c63e481 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -81,3 +81,55 @@ in Qt.")
(description "liblxqt provides the basic libraries shared by the
components of the LxQt desktop environment.")
(license lgpl2.1+)))
+
+
+(define-public lxqt-common
+ (package
+ (name "lxqt-common")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://downloads.lxqt.org/lxqt/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0kbkwmrdjhfbq60wf2yfbsjmci8xlw13ilxxa7yxq68n1aqjqmvf"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-installation-paths
+ (lambda _
+ ;; The variable LXQT_ETC_XDG_DIR is set in
+ ;; liblxqt-0.9.0/share/cmake/lxqt/lxqt-config.cmake
+ ;; to the Qt5 installation directory, followed by "/etc/xdg".
+ ;; We need to have it point to the current installation
+ ;; directory instead.
+ (substitute* '("config/CMakeLists.txt"
+ "menu/CMakeLists.txt")
+ (("\\$\\{LXQT_ETC_XDG_DIR\\}")
+ "${CMAKE_INSTALL_PREFIX}/etc/xdg")
+ ;; In the same file, LXQT_SHARE_DIR is set to the installation
+ ;; directory of liblxqt, followed by "/share/lxqt".
+ (("\\$\\{LXQT_SHARE_DIR\\}")
+ "${CMAKE_INSTALL_PREFIX}/share/lxqt"))
+ ;; Replace absolute directories.
+ (substitute* "autostart/CMakeLists.txt"
+ (("/etc/xdg")
+ "${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ (substitute* "xsession/CMakeLists.txt"
+ (("/usr/share")
+ "${CMAKE_INSTALL_PREFIX}/share")))))))
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)))
+ (home-page "http://lxqt.org/")
+ (synopsis "Common files for LXQt")
+ (description "lxqt-common provides the desktop integration files
+(themes, icons, configuration files etc.) for the LXQt
+desktop environment.")
+ (license lgpl2.1+)))