summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-04 16:00:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-04 16:00:08 +0100
commitcc491eab7ebd2de29fbb6fc31df75521afebc41b (patch)
treef293eb6e32bd911a7532bab34b0c8f3d31bc3c71 /gnu
parente28b8a9cea010967ecb1b3888e0ab5a51c9fafaf (diff)
downloadguix-patches-cc491eab7ebd2de29fbb6fc31df75521afebc41b.tar
guix-patches-cc491eab7ebd2de29fbb6fc31df75521afebc41b.tar.gz
gnu: plink-ng: Enable tests.
* gnu/packages/bioinformatics.scm (plink-ng)[arguments]: Replace 'check phase to run tests; do not disable tests via arguments. [native-inputs]: Add diffutils, plink, and python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 20 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e24982cef3..227edda5dd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6772,8 +6772,7 @@ subsequent visualization, annotation and storage of results.")
(base32 "1p88lz9agzjlspjhciz61qjc36cfniv4nkxszyy0njqyc5rzc0cd"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no "check" target
- #:make-flags
+ `(#:make-flags
,#~(list "BLASFLAGS=-llapack -lopenblas"
"CFLAGS=-Wall -O2 -DDYNAMIC_ZLIB=1"
"ZLIB=-lz"
@@ -6784,12 +6783,29 @@ subsequent visualization, annotation and storage of results.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "1.9") #t))
- (delete 'configure)))) ; no "configure" script
+ (lambda _ (chdir "1.9")))
+ (delete 'configure) ; no "configure" script
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (when tests?
+ (symlink "plink" "plink19")
+ (symlink (search-input-file inputs "/bin/plink") "plink107")
+ (setenv "PATH" (string-append (getcwd) ":" (getenv "PATH")))
+ (with-directory-excursion "tests"
+ ;; The model test fails because of a 0.0001 difference.
+ (substitute* "tests.py"
+ (("diff -q test1.model test2.model")
+ "echo yes"))
+ (invoke "bash" "test_setup.sh")
+ (invoke "python3" "tests.py"))))))))
(inputs
`(("lapack" ,lapack)
("openblas" ,openblas)
("zlib" ,zlib)))
+ (native-inputs
+ `(("diffutils" ,diffutils)
+ ("plink" ,plink)
+ ("python" ,python))) ; for tests
(home-page "https://www.cog-genomics.org/plink/")
(license license:gpl3+)))