summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-02 22:44:02 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-02 22:44:02 +0200
commitbef4dd92e4bef7c56eceaf6278eb9fcc046cb673 (patch)
tree80deee42349f38c4956976f388898aff5f41d596 /gnu
parent7d3f36518dc3314c2023ac5ad17383978b559a77 (diff)
downloadguix-patches-bef4dd92e4bef7c56eceaf6278eb9fcc046cb673.tar
guix-patches-bef4dd92e4bef7c56eceaf6278eb9fcc046cb673.tar.gz
gnu: Add hicolor-icon-theme.
* gnu/packages/gnome.scm (hicolor-icon-theme): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 66d4b4ee0d..5d67f34e98 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -17,7 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gnome)
- #:use-module ((guix licenses) #:select (gpl2+ lgpl2.1+ lgpl3))
+ #:use-module ((guix licenses) #:select (gpl2 gpl2+ lgpl2.1+ lgpl3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -136,6 +136,28 @@ GNOME and KDE desktops to the icon names proposed in the specification.")
"Icons for the GNOME desktop.")
(license lgpl3))) ; or Creative Commons BY-SA 3.0
+(define-public hicolor-icon-theme
+ (package
+ (name "hicolor-icon-theme")
+ (version "0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://icon-theme.freedesktop.org/releases/hicolor-icon-theme-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0wzc7g4ldb2l8zc0x2785ck808c03i857jji942ikakyc68adp4y"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no check target
+ (home-page "http://icon-theme.freedesktop.org/releases/")
+ (synopsis
+ "Freedesktop icon theme")
+ (description
+ "Freedesktop icon theme.")
+ (license gpl2)))
+
(define-public libnotify
(package
(name "libnotify")