summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:13:16 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:20 +0200
commit979e18fa9d6cc62c5928c72a58999cdfd2561430 (patch)
treee70b2f37cb3a9b81aa7d430ccbd8247fe7efe1be /gnu
parent5801d21fd4a42cb3b8720b2da43e240430b468ad (diff)
downloadguix-patches-979e18fa9d6cc62c5928c72a58999cdfd2561430.tar
guix-patches-979e18fa9d6cc62c5928c72a58999cdfd2561430.tar.gz
gnu: Add kpackage.
* gnu/packages/kde-frameworks.scm (kpackage): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0e39a4a56c..eed6fffd96 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1332,3 +1332,40 @@ asynchronous jobs.")
(description "KNotification is used to notify the user of an event. It
covers feedback and persistent events.")
(license license:lgpl2.1+)))
+
+(define-public kpackage
+ (package
+ (name "kpackage")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "03aqzkpqz3c1v4qgwfbs3ncdbapiyg7psrkhxqv3z48rklavk1ri"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("karchive" ,karchive)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:tests? #f ; FIXME: 1/4 tests fail.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* _
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug output
+ (setenv "HOME" (getcwd)))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Installation and loading of additional content as packages")
+ (description "The Package framework lets the user install and load packages
+of non binary content such as scripted extensions or graphic assets, as if they
+were traditional plugins.")
+ (license (list license:gpl2+ license:lgpl2.1+))))