summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:52 +0200
commit96b966a35924d19f28e64a2307911dd472e5d979 (patch)
treee1b752a00d1da4a36312b94b139f2c4cc9802493 /gnu
parent797d0bcb1a7313eb14e1494d21149900f2ba032b (diff)
downloadguix-patches-96b966a35924d19f28e64a2307911dd472e5d979.tar
guix-patches-96b966a35924d19f28e64a2307911dd472e5d979.tar.gz
gnu: Add r-ggnetwork.
* gnu/packages/cran.scm (r-ggnetwork): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 572dcb7ad7..7205d3d748 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9655,6 +9655,33 @@ and coverage methods to tune the choice of threshold.")
@end enumerate")
(license license:gpl3)))
+(define-public r-ggnetwork
+ (package
+ (name "r-ggnetwork")
+ (version "0.5.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggnetwork" version))
+ (sha256
+ (base32
+ "0gqdgy5yh700dg0f7xb80hczlnqfisn8l55j7amd1n7fp2x5sr8v"))))
+ (properties `((upstream-name . "ggnetwork")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-igraph" ,r-igraph)
+ ("r-network" ,r-network)
+ ("r-sna" ,r-sna)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/briatte/ggnetwork")
+ (synopsis "Geometries to plot networks with ggplot2")
+ (description
+ "This package provides geometries to plot network objects with the
+ggplot2 package.")
+ (license license:gpl3)))
+
(define-public r-mosaiccore
(package
(name "r-mosaiccore")