summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-12-01 16:53:54 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-12-04 19:50:30 +0200
commit7c8e9cbfa99f35d638bc92c03a06d3a35754ede1 (patch)
treeaa2fef50ad816dde66bdd21ab27801ac573118d3 /gnu
parentdcd7c950c62ca047c4c38d9e2caf2c43f3b805cb (diff)
downloadguix-patches-7c8e9cbfa99f35d638bc92c03a06d3a35754ede1.tar
guix-patches-7c8e9cbfa99f35d638bc92c03a06d3a35754ede1.tar.gz
gnu: julia-mappedarrays: Fix tests on i686-linux.
* gnu/packages/julia-xyz.scm (julia-mappedarrays)[arguments]<#:phases>: Conditionally replace the incorrect type in test suite. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0ae515cdd2..f90901b52d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2901,6 +2901,15 @@ that let you do deep transformations of code.")
(sha256
(base32 "0l5adird8m1cmnsxwhzi5hcr7q9bm1rf7a6018zc7kcn2yxdshy3"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-64bit?)
+ '(%standard-phases)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-fixedpointnumbers" ,julia-fixedpointnumbers)))
(native-inputs