summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 22:26:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 22:26:20 +0200
commit7ad3c81240b366b99f29c4ac5f7c42173c91f38a (patch)
treee2abeb464bd74d78d3ad23d49dfb24fb104610ae /gnu
parentba6008760a84b22d71f3d70e6a15f7d89960b4bf (diff)
downloadguix-patches-7ad3c81240b366b99f29c4ac5f7c42173c91f38a.tar
guix-patches-7ad3c81240b366b99f29c4ac5f7c42173c91f38a.tar.gz
gnu: gsl: Update to 2.6.
* gnu/packages/maths.scm (gsl): Update to 2.6. [source]: Remove patch. * gnu/packages/patches/gsl-test-i686.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm5
-rw-r--r--gnu/packages/patches/gsl-test-i686.patch17
3 files changed, 2 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4cf68dcfd9..e97a5083d1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -938,7 +938,6 @@ dist_patch_DATA = \
%D%/packages/patches/grep-timing-sensitive-test.patch \
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
%D%/packages/patches/grub-efi-fat-serial-number.patch \
- %D%/packages/patches/gsl-test-i686.patch \
%D%/packages/patches/gspell-dash-test.patch \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-2.2-default-utf8.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 16a9d97a47..fd7159a411 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -375,15 +375,14 @@ semiconductors.")
(define-public gsl
(package
(name "gsl")
- (version "2.5")
+ (version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gsl/gsl-"
version ".tar.gz"))
(sha256
(base32
- "1395y9hlhqadn5g9j8q22224fds5sd92jxi9czfavjj24myasq04"))
- (patches (search-patches "gsl-test-i686.patch"))))
+ "1a460zj9xmbgvcymkdhqh313c4l29mn9cffbi5vf33x3qygk70mp"))))
(build-system gnu-build-system)
(arguments
`(;; Currently there are numerous tests that fail on "exotic"
diff --git a/gnu/packages/patches/gsl-test-i686.patch b/gnu/packages/patches/gsl-test-i686.patch
deleted file mode 100644
index 8828c08614..0000000000
--- a/gnu/packages/patches/gsl-test-i686.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Work around a test failure due to a rounding issue on 32-bit
-platforms, as reported at:
-
- https://lists.gnu.org/archive/html/bug-gsl/2016-10/msg00000.html
-
---- gsl-2.2.1/linalg/test.c 2016-10-05 13:27:42.464059730 +0200
-+++ gsl-2.2.1/linalg/test.c 2016-10-05 13:27:46.988095882 +0200
-@@ -4843,9 +4843,6 @@ main(void)
- gsl_test(test_cholesky_decomp_unit(), "Cholesky Decomposition [unit triangular]");
- gsl_test(test_cholesky_solve(), "Cholesky Solve");
-
-- gsl_test(test_cholesky_decomp(r), "Cholesky Decomposition");
-- gsl_test(test_cholesky_invert(r), "Cholesky Inverse");
-- gsl_test(test_pcholesky_decomp(r), "Pivoted Cholesky Decomposition");
- gsl_test(test_pcholesky_solve(r), "Pivoted Cholesky Solve");
- gsl_test(test_pcholesky_invert(r), "Pivoted Cholesky Inverse");
- gsl_test(test_mcholesky_decomp(r), "Modified Cholesky Decomposition");