summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-01-28 12:27:58 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-01-28 12:30:41 +0800
commit736cfc10f0891f1626a3d78c7c304ba6a42ba93b (patch)
tree48b3f632972060165c9276d477a5e976b5cb3f25 /gnu
parent0b5e08637e047d9564053701d40a463933046ee8 (diff)
downloadguix-patches-736cfc10f0891f1626a3d78c7c304ba6a42ba93b.tar
guix-patches-736cfc10f0891f1626a3d78c7c304ba6a42ba93b.tar.gz
gnu: python-xdo: Hardcode the path of 'libxdo.so'.
* gnu/packages/python.scm (python-xdo)[arguments]: Add 'patch-libxdo-path' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index df211fb99f..9e33412d88 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8855,7 +8855,19 @@ normally the case.")
"1vqh1n5yy5dhnq312kwrl90fnck4v26is3lq3lxdvcn60vv19da0"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ; no tests provided
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-libxdo-path
+ ;; Hardcode the path of dynamically loaded libxdo library.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libxdo (string-append
+ (assoc-ref inputs "xdotool")
+ "/lib/libxdo.so")))
+ (substitute* "xdo/_xdo.py"
+ (("find_library\\(\"xdo\"\\)")
+ (simple-format #f "\"~a\"" libxdo)))
+ #t))))
+ #:tests? #f)) ; no tests provided
(propagated-inputs
`(("python-six" ,python-six)))
(inputs