summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-03 13:53:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-03 13:56:02 +0100
commit6d4f260166eb499564fa31ce487ecf301f445e4e (patch)
treebf567799966d740c15942b4b9dc13d03b25c84b6 /gnu
parent673cc2990807e36308cce4b20a8a6f1501b0f4b3 (diff)
downloadguix-patches-6d4f260166eb499564fa31ce487ecf301f445e4e.tar
guix-patches-6d4f260166eb499564fa31ce487ecf301f445e4e.tar.gz
gnu: bamutils: Update to 1.0.14.
* gnu/packages/bioinformatics.scm (bamutils): Update to 1.0.14. [arguments]: Patch DATE for reproducibility; prepare sources of libstatgen. [native-inputs]: Add sources of libstatgen.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 25 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 27eccadd1e..be3fce6f70 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -324,27 +324,43 @@ BAM files.")
(define-public bamutils
(package
(name "bamutils")
- (version "1.0.13")
+ (version "1.0.14")
(source (origin
- (method url-fetch)
- (uri
- (string-append
- "https://genome.sph.umich.edu/w/images/7/70/"
- "BamUtilLibStatGen." version ".tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/statgen/bamUtil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0asr1kmjbr3cyf4hkg865y8c2s30v87xvws4q6c8pyfi6wfd1h8n"))))
+ "0i2r332k1kz0jysyg89d858wqq59n16lw6dv5qmilcwshb77r9v7"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; There are no tests.
+ `(#:tests? #f ; Unclear how to run tests
#:make-flags
,#~(list "USER_WARNINGS=-std=gnu++98" ;
(string-append "INSTALLDIR=" #$output "/bin"))
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/Makefile" ;
+ (("^DATE=.*") "DATE=\"1970-01-01\"\n"))
+ (copy-recursively (assoc-ref inputs "libstatgen")
+ "../libStatGen"))))))
(inputs
`(("zlib" ,zlib)))
+ (native-inputs
+ `(("libstatgen"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/statgen/libStatGen/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "libstatgen" version))
+ (sha256
+ (base32
+ "0q9iyk046r4m7qnav8c3f28zsar25lj9nydiklwaswmzdijhi4p1"))))))
(home-page "https://genome.sph.umich.edu/wiki/BamUtil")
(synopsis "Programs for working on SAM/BAM files")
(description "This package provides several programs that perform