summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-03 09:03:18 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-04 22:39:46 +0100
commit3f03f502ee612adfcb41c7e849b2a79eb5e949d3 (patch)
tree29b762fe174fd6cd2a6fa3a5b8ceb3fa387a0757 /gnu
parent634b46a469cbb78e80419f047605c05930e7ff10 (diff)
downloadguix-patches-3f03f502ee612adfcb41c7e849b2a79eb5e949d3.tar
guix-patches-3f03f502ee612adfcb41c7e849b2a79eb5e949d3.tar.gz
gnu: libgda: Do not use the bundled sqlite.
* gnu/packages/gnome.scm (libgda)[source]: Add snippet. [arguments]: Pass "--enable-system-sqlite". [inputs]: Add SQLITE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bada1e866b..1685470ced 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12703,10 +12703,15 @@ developed with the aim of being used with the Librem 5 phone.")
version "." "_")))))
(file-name (git-file-name name version))
(sha256
- (base32 "18rg773gq9v3cdywpmrp12c5xyp97ir9yqjinccpi22sksb1kl8a"))))
+ (base32 "18rg773gq9v3cdywpmrp12c5xyp97ir9yqjinccpi22sksb1kl8a"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove the bundled sqlite, but keep its header because code relies
+ ;; on this header variant.
+ '(delete-file "libgda/sqlite/sqlite-src/sqlite3.c"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--enable-vala")
+ `(#:configure-flags '("--enable-system-sqlite" "--enable-vala")
;; There's a race between check_cnc_lock and check_threaded_cnc
;; in tests/multi-threading.
#:parallel-tests? #f
@@ -12745,6 +12750,7 @@ developed with the aim of being used with the Librem 5 phone.")
("libsecret" ,libsecret)
("libxslt" ,libxslt)
("openssl" ,openssl)
+ ("sqlite" ,sqlite)
("vala" ,vala)))
(native-inputs
`(("autoconf" ,autoconf)