summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-18 14:13:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-08-19 15:49:15 +0200
commit349cef585da5e60b5c8b3e0a31f3c05f600354e1 (patch)
tree37953f4bf07ddb4c00abf5ae52404ca1e12cb069 /gnu
parent735b8db6caac0adabfd6a5700b6ac6b9e23f2c1b (diff)
downloadguix-patches-349cef585da5e60b5c8b3e0a31f3c05f600354e1.tar
guix-patches-349cef585da5e60b5c8b3e0a31f3c05f600354e1.tar.gz
gnu: rhythmbox: Update to 3.4.
* gnu/packages/gnome.scm (rhythmbox): Update to 3.4. [arguments]: Add PYTHONPATH environment variable to 'wrap-program'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f12b9774a3..43d31bf122 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3264,7 +3264,7 @@ which can read a large number of file formats.")
(define-public rhythmbox
(package
(name "rhythmbox")
- (version "3.2.1")
+ (version "3.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3272,7 +3272,7 @@ which can read a large number of file formats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0f3radhlji7rxl760yl2vm49fvfslympxrpm8497acbmbd7wlhxz"))))
+ "1347747m90aiz47wny1f8rdk5195qf2ph0554c6y91711sm951gg"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags
@@ -3290,11 +3290,13 @@ which can read a large number of file formats.")
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
- (grl-plugin-path (getenv "GRL_PLUGIN_PATH")))
+ (grl-plugin-path (getenv "GRL_PLUGIN_PATH"))
+ (python-path (getenv "PYTHONPATH")))
(wrap-program (string-append out "/bin/rhythmbox")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GRL_PLUGIN_PATH" ":" prefix (,grl-plugin-path))))
+ `("GRL_PLUGIN_PATH" ":" prefix (,grl-plugin-path))
+ `("PYTHONPATH" ":" prefix (,python-path))))
#t)))))
(propagated-inputs
`(("dconf" ,dconf)))
@@ -3340,7 +3342,6 @@ which can read a large number of file formats.")
;; TODO:
;; * libgpod
;; * mx
- ;; * webkit
("brasero" ,brasero)))
(home-page "https://wiki.gnome.org/Apps/Rhythmbox")
(synopsis "Music player for GNOME")