summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 17:34:32 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:58 +0200
commit28e997e88b692fde9ba5c61213b26962cb473c95 (patch)
tree1898e7b2276121d779c53bfd7a75783af1e0f75e /gnu
parentde84d3b1e230bc90c6a12153e2e59b7e09b41ab7 (diff)
downloadguix-patches-28e997e88b692fde9ba5c61213b26962cb473c95.tar
guix-patches-28e997e88b692fde9ba5c61213b26962cb473c95.tar.gz
gnu: Add python-jsonplus.
* gnu/packages/python-xyz.scm (python-jsonplus): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3094b07c6d..0e9809ebfe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19876,6 +19876,31 @@ hard (or impossible without root privileges) to set the state of the real
services to what you expect in your tests.")
(license license:lgpl3+)))
+(define-public python-jsonplus
+ (package
+ (name "python-jsonplus")
+ (version "0.8.0")
+ (home-page "https://github.com/randomir/jsonplus")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonplus" version))
+ (sha256
+ (base32
+ "05yv3dw813zwas9snz124k2hki49y268b3mx0gj9w7v1nrjmglq1"))))
+ (build-system python-build-system)
+ ;; XXX: No tests on PyPI, and the repository has no tags.
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-simplejson" ,python-simplejson)
+ ("python-sortedcontainers" ,python-sortedcontainers)))
+ (synopsis "Serialize Python types to/from JSON")
+ (description
+ "This package provides functionality to serialize arbitrary data types
+to and from JSON. Common data types are implemented and it is easy to
+register custom encoders and decoders.")
+ (license license:expat)))
+
(define-public python-ujson
(package
(name "python-ujson")