summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-01-27 14:43:44 +0100
committerAlex Kost <alezost@gmail.com>2017-01-28 12:41:35 +0300
commit1e523180ae52ab5646fd0cb8e589d5acc3e9e713 (patch)
tree31f3f7a5217c991a9ea8cc72186cac8b62c00487 /gnu
parent1c6713465fbc3f1c0367e09ca7cb2921966cdf95 (diff)
downloadguix-patches-1e523180ae52ab5646fd0cb8e589d5acc3e9e713.tar
guix-patches-1e523180ae52ab5646fd0cb8e589d5acc3e9e713.tar.gz
gnu: Add emacs-ht.
* gnu/packages/emacs.scm (emacs-ht): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 06f624486b..4737a81ce7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3646,3 +3647,27 @@ Streams are implemented as delayed evaluation of cons cells.")
(description "This package provides expression based interactive search
procedures for emacs-lisp-mode.")
(license license:gpl3+))))
+
+(define-public emacs-ht
+ (package
+ (name "emacs-ht")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Wilfred/ht.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lpba36kzxcc966fvsbrfpy8ah9gnvay0yk26gbyjil0rggrbqzj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/Wilfred/ht.el")
+ (synopsis "Hash table library for Emacs")
+ (description
+ "This package simplifies the use of hash tables in elisp. It also
+provides functions to convert hash tables from and to alists and plists.")
+ (license license:gpl3+)))
+