summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2017-02-21 14:17:41 -0500
committerRicardo Wurmus <rekado@elephly.net>2017-10-10 23:09:40 +0200
commit9074bac1391b4db5cf33f3cb9f86f38061e97ae9 (patch)
treec9dd55d19ba3f0a57ca860da3037beca285ce3a2 /gnu
parentbb3b4b4ee98d15273c34a8bd7bf8e8a3a07d7390 (diff)
downloadguix-patches-9074bac1391b4db5cf33f3cb9f86f38061e97ae9.tar
guix-patches-9074bac1391b4db5cf33f3cb9f86f38061e97ae9.tar.gz
gnu: Add python-constantly.
* gnu/packages/python.scm (python-constantly, python2-constantly): New variables. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f4010b6928..3adab71d12 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14228,6 +14228,27 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-constantly
+ (package
+ (name "python-constantly")
+ (version "15.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "constantly" version))
+ (sha256
+ (base32
+ "0dgwdla5kfpqz83hfril716inm41hgn9skxskvi77605jbmp4qsq"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/twisted/constantly")
+ (synopsis "Symbolic constants in Python")
+ (description "Constantly is a Python library that provides symbolic
+constant support. It includes collections and constants with text, numeric,
+and bit flag values.")
+ (license license:expat)))
+
+(define-public python2-constantly
+ (package-with-python2 python-constantly))
+
(define-public python-attrs
(package
(name "python-attrs")