summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-04 21:12:17 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-10 22:05:57 +0200
commit40f193f31668a90fc936358e4d9e3f28b041505f (patch)
tree893cf74509467739ac25d4bf3c6751580b5d1452 /gnu
parent6fd07b98b144c239d27475d2bfac5ec3ee66be16 (diff)
downloadguix-patches-40f193f31668a90fc936358e4d9e3f28b041505f.tar
guix-patches-40f193f31668a90fc936358e4d9e3f28b041505f.tar.gz
gnu: Add java-woodstox-core.
* gnu/packages/java.scm (java-woodstox-core): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 993bffe640..507fd086d3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -5925,3 +5925,41 @@ abstractions.")
significant new functionalities, such as full-featured bi-direction validation
interface and high-performance Typed Access API.")
(license license:bsd-2)))
+
+(define-public java-woodstox-core
+ (package
+ (name "java-woodstox-core")
+ (version "5.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/FasterXML/woodstox/archive/"
+ "woodstox-core-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1i7pdgb8jbw6gdy5kmm0l6rz109n2ns92pqalpyp24vb8vlvdfd4"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "woodstox.jar"
+ #:test-exclude
+ (list "**/Base*.java" "failing/**")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'remove-msv-dep
+ (lambda _
+ ;; we don't need osgi, and it depends on msv
+ (delete-file-recursively "src/main/java/com/ctc/wstx/osgi")
+ ;; msv's latest release is from 2011 and we don't need it
+ (delete-file-recursively "src/main/java/com/ctc/wstx/msv")
+ (delete-file-recursively "src/test/java/wstxtest/osgi")
+ (delete-file-recursively "src/test/java/wstxtest/msv")))
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "src/main/resources" "build/classes"))))))
+ (inputs
+ `(("stax2" ,java-stax2-api)))
+ (native-inputs
+ `(("junit" ,java-junit)))
+ (home-page "https://github.com/FasterXML/woodstox")
+ (synopsis "Stax XML API implementation")
+ (description "Woodstox is a stax XML API implementation.")
+ (license license:asl2.0)))