summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-01 12:41:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-01 12:41:59 +0200
commit93c97bfffba7ca0126c03967fbe058354e24f84d (patch)
tree67f53172efec753d4e5813c8b3da9fe3488b30e3 /gnu
parent6e54ce9ca9b172189ab46eb14147304ff9cfa35b (diff)
downloadguix-patches-93c97bfffba7ca0126c03967fbe058354e24f84d.tar
guix-patches-93c97bfffba7ca0126c03967fbe058354e24f84d.tar.gz
gnu: pigx-bsseq: Update to 0.1.7.
* gnu/packages/bioinformatics.scm (pigx-bsseq): Update to 0.1.7. [source]: Remove patch. [arguments]: Remove 'autoreconf phase. [native-inputs]: Remove automake and autoconf. * gnu/packages/patches/pigx-bsseq-no-citeproc.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm19
-rw-r--r--gnu/packages/patches/pigx-bsseq-no-citeproc.patch33
3 files changed, 3 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b9d62a3f0f..c7625a7679 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1628,7 +1628,6 @@ dist_patch_DATA = \
%D%/packages/patches/picard-fix-id3-rename-test.patch \
%D%/packages/patches/picprog-non-intel-support.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
- %D%/packages/patches/pigx-bsseq-no-citeproc.patch \
%D%/packages/patches/pinball-system-ltdl.patch \
%D%/packages/patches/pingus-boost-headers.patch \
%D%/packages/patches/pingus-sdl-libs-config.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f2800d3163..92d92e7d02 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10608,7 +10608,7 @@ in an easily configurable manner.")
(define-public pigx-bsseq
(package
(name "pigx-bsseq")
- (version "0.1.6")
+ (version "0.1.7")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_bsseq/"
@@ -10616,8 +10616,7 @@ in an easily configurable manner.")
"/pigx_bsseq-" version ".tar.gz"))
(sha256
(base32
- "1dipikph0xdr8fp0h1flpafcrg60y4aabljg8fl1v92j3gxdggmw"))
- (patches (search-patches "pigx-bsseq-no-citeproc.patch"))))
+ "1hfiignq3410dbl6f67vc6zr69abknpcgxixx475dspky2jb5lyn"))))
(build-system gnu-build-system)
(arguments
`(;; TODO: tests currently require 12+GB of RAM. See
@@ -10625,18 +10624,6 @@ in an easily configurable manner.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-before 'bootstrap 'autoreconf
- (lambda _
- ;; This was fixed in commit
- ;; d56ac732524da659afbbb0972f7a87fa178ae58e, but there is no
- ;; release with this fix.
- (call-with-output-file "VERSION"
- (lambda (port) (display ,version port)))
- ;; https://github.com/BIMSBbioinfo/pigx_bsseq/issues/181
- (substitute* "m4/ax_r_package.m4"
- (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
- "if(system.file(package=\"PKG\") == \"\")"))
- (invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _
(setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH"))))
@@ -10648,7 +10635,7 @@ in an easily configurable manner.")
(search-input-directory inputs
"share/zoneinfo")))))))
(native-inputs
- (list tzdata automake autoconf))
+ (list tzdata))
(inputs
(list coreutils
sed
diff --git a/gnu/packages/patches/pigx-bsseq-no-citeproc.patch b/gnu/packages/patches/pigx-bsseq-no-citeproc.patch
deleted file mode 100644
index 882e660fe4..0000000000
--- a/gnu/packages/patches/pigx-bsseq-no-citeproc.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur pigx_bsseq-0.1.5/configure.ac pigx_bsseq-0.1.5.patched/configure.ac
---- pigx_bsseq-0.1.5/configure.ac 2021-06-08 15:28:08.000000000 +0200
-+++ pigx_bsseq-0.1.5.patched/configure.ac 2021-10-05 14:43:56.806529137 +0200
-@@ -38,7 +38,6 @@
- find_or_override_prog([GNUBASH], [bash])
- find_or_override_prog([SNAKEMAKE], [snakemake])
- find_or_override_prog([PANDOC], [pandoc])
--find_or_override_prog([PANDOC_CITEPROC], [pandoc-citeproc])
- find_or_override_prog([FASTQC], [fastqc])
- find_or_override_prog([MULTIQC], [multiqc])
- find_or_override_prog([TRIMGALORE], [trim_galore])
-diff -Naur pigx_bsseq-0.1.5/Makefile.in pigx_bsseq-0.1.5.patched/Makefile.in
---- pigx_bsseq-0.1.5/Makefile.in 2021-06-08 16:17:03.000000000 +0200
-+++ pigx_bsseq-0.1.5.patched/Makefile.in 2021-10-05 14:43:34.635876855 +0200
-@@ -408,7 +408,6 @@
- PACKAGE_URL = @PACKAGE_URL@
- PACKAGE_VERSION = @PACKAGE_VERSION@
- PANDOC = @PANDOC@
--PANDOC_CITEPROC = @PANDOC_CITEPROC@
- PATH_SEPARATOR = @PATH_SEPARATOR@
- PYTHON = @PYTHON@
- PYTHONPATH = @PYTHONPATH@
-diff -Naur pigx_bsseq-0.1.5/pigx-common/common/pigx-runner.in pigx_bsseq-0.1.5.patched/pigx-common/common/pigx-runner.in
---- pigx_bsseq-0.1.5/pigx-common/common/pigx-runner.in 2021-06-08 10:14:29.000000000 +0200
-+++ pigx_bsseq-0.1.5.patched/pigx-common/common/pigx-runner.in 2021-10-05 14:43:44.296161069 +0200
-@@ -375,7 +375,6 @@
- if path.exists(bin): shutil.rmtree(bin)
- os.makedirs(bin, exist_ok=True)
- os.symlink('@PANDOC@', path.join(bin, "pandoc"))
-- os.symlink('@PANDOC_CITEPROC@', path.join(bin, "pandoc-citeproc"))
- os.symlink('@RSCRIPT@', path.join(bin, "Rscript"))
- os.environ['PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
- os.environ['PIGX_PATH'] = path.abspath(bin) + ":" + os.environ['PATH']