summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-02 09:03:14 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-09-04 14:53:32 +0200
commit8ceb7651c2aff73644a49c1d72fe8b63948f0240 (patch)
treed4672723a1d94554e88be651e35176f18987fdef /gnu
parent1fd0bf60ea261fac426052386029ead0ac68cad1 (diff)
downloadguix-patches-8ceb7651c2aff73644a49c1d72fe8b63948f0240.tar
guix-patches-8ceb7651c2aff73644a49c1d72fe8b63948f0240.tar.gz
gnu: python-confuse: Update to 1.5.0.
* gnu/packages/python-xyz.scm (python-confuse)[version]: Update to 1.5.0. [propagated-inputs]: Remove python-pathlib. [synopsis]: Remove trailing dot.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55858fbf8e..12adafa892 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -107,6 +107,7 @@
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25909,20 +25910,19 @@ Qt applications.")
(define-public python-confuse
(package
(name "python-confuse")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "confuse" version))
(sha256
(base32
- "0r74djc8r6lfx6ldsqnhpvfsn256gsfzbl33qcm77hp2qr8h9z4j"))))
+ "0bh2kyj8wd7h9gg4nsvrbykl5ly0f70f0wi3fbm204b1f0fcmywj"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-pathlib" ,python-pathlib)
- ("python-pyyaml" ,python-pyyaml)))
+ `(("python-pyyaml" ,python-pyyaml)))
(home-page "https://github.com/beetbox/confuse")
- (synopsis "Painless YAML configuration.")
+ (synopsis "Painless YAML configuration")
(description "Confuse is a configuration library for Python that uses
YAML. It takes care of defaults, overrides, type checking, command-line
integration, human-readable errors, and standard OS-specific locations.")