summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 17:38:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 17:38:15 +0100
commit6db3c536e89deb8a204e756f427614925a7d2582 (patch)
treef74311ea0a05730d0123f677183433bc5a382df8 /gnu
parentdd67154e5d3ceffad5ead300ffa506af65acc0fc (diff)
downloadguix-patches-6db3c536e89deb8a204e756f427614925a7d2582.tar
guix-patches-6db3c536e89deb8a204e756f427614925a7d2582.tar.gz
gnu: python-bwapy: Remove sanity-check.
* gnu/packages/bioinformatics.scm (python-bwapy)[arguments]: Add phase 'relax-requirements to accept a slightly older version of wheel; remove the 'sanity-check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1aa61ce2e6..f8551b7723 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15509,6 +15509,16 @@ sequences")
(snippet
'(for-each delete-file (find-files "." "\\.o$")))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("wheel>=0.34") "wheel>=0.30"))))
+ ;; TODO: it's possible that the import error points to a real
+ ;; problem with the C sources.
+ (delete 'sanity-check))))
(propagated-inputs
`(("python-cffi" ,python-cffi)
("python-setuptools" ,python-setuptools)